CVE-2024-31228
CVE-2024-31228 · Denial-of-service due to unbounded pattern matching in Redis
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Redis is an open source, in-memory database that persists on disk. Authenticated users can trigger a denial-of-service by using specially crafted, long string match patterns on supported commands such as `KEYS`, `SCAN`, `PSUBSCRIBE`, `FUNCTION LIST`, `COMMAND LIST` and ACL definitions. Matching of extremely long patterns may result in unbounded recursion, leading to stack overflow and process crash. This problem has been fixed in Redis versions 6.2.16, 7.2.6, and 7.4.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 5.5 · Media · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
redis
- Versiones
- >= 2.2.5, < 6.2.16: Afectada
- >= 7.0.0, < 7.2.6: Afectada
- >= 7.3.0, < 7.4.1: Afectada
Sin corrección publicada
redict Debian:14
- Versiones
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.3.1+ds-1
Actualiza a 7.3.1+ds-1
redis Debian:12
- Versiones
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1~deb12u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-1~deb12u2
Actualiza a 5:7.0.15-1~deb12u2
redis Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-2
Actualiza a 5:7.0.15-2
redis Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-2
Actualiza a 5:7.0.15-2
valkey Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.0.1+dfsg1-1
Actualiza a 8.0.1+dfsg1-1
valkey Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.0.1+dfsg1-1
Actualiza a 8.0.1+dfsg1-1
redis Ubuntu:Pro:16.04:LTS
- Versiones
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- 2:3.0.6-1ubuntu0.4+esm1
- 2:3.0.6-1ubuntu0.4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:3.0.6-1ubuntu0.4+esm3
Actualiza a 2:3.0.6-1ubuntu0.4+esm3
redis Ubuntu:Pro:18.04:LTS
- Versiones
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- 5:4.0.9-1ubuntu0.2+esm3
- 5:4.0.9-1ubuntu0.2+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm5
Actualiza a 5:4.0.9-1ubuntu0.2+esm5
redis Ubuntu:Pro:20.04:LTS
- Versiones
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- 5:5.0.7-2ubuntu0.1+esm1
- 5:5.0.7-2ubuntu0.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm3
Actualiza a 5:5.0.7-2ubuntu0.1+esm3
redis Ubuntu:Pro:22.04:LTS
- Versiones
- 5:6.0.15-1
- 5:6.0.16-1
- 5:6.0.16-1build1
- 5:6.0.16-1ubuntu1
- 5:6.0.16-1ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.16-1ubuntu1+esm2
Actualiza a 5:6.0.16-1ubuntu1+esm2
redis Ubuntu:24.04:LTS
- Versiones
- 5:7.0.12-1
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1
- 5:7.0.15-1build1
- 5:7.0.15-1build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-1ubuntu0.24.04.1
Actualiza a 5:7.0.15-1ubuntu0.24.04.1