CVE-2024-32462
CVE-2024-32462 · Flatpak vulnerable to a sandbox escape via RequestBackground portal due to bad argument parsing
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Flatpak is a system for building, distributing, and running sandboxed desktop applications on Linux. in versions before 1.10.9, 1.12.9, 1.14.6, and 1.15.8, a malicious or compromised Flatpak app could execute arbitrary code outside its sandbox. Normally, the `--command` argument of `flatpak run` expects to be given a command to run in the specified Flatpak app, optionally along with some arguments. However it is possible to instead pass `bwrap` arguments to `--command=`, such as `--bind`. It's possible to pass an arbitrary `commandline` to the portal interface `org.freedesktop.portal.Background.RequestBackground` from within a Flatpak app. When this is converted into a `--command` and arguments, it achieves the same effect of passing arguments directly to `bwrap`, and thus can be used for a sandbox escape. The solution is to pass the `--` argument to `bwrap`, which makes it stop processing options. This has been supported since bubblewrap 0.3.0. All supported versions of Flatpak require at least that version of bubblewrap. xdg-desktop-portal version 1.18.4 will mitigate this vulnerability by only allowing Flatpak apps to create .desktop files for commands that do not start with --. The vulnerability is patched in 1.15.8, 1.10.9, 1.12.9, and 1.14.6.
CVSS 8.4 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
flatpak
- Versiones
- < 1.10.9: Afectada
- >= 1.12.0, < 1.12.9: Afectada
- >= 1.14.0, < 1.14.6: Afectada
- >= 1.15.0, < 1.15.8: Afectada
Sin corrección publicada
flatpak Debian:12
- Versiones
- 1.14.4-1
- 1.14.4-1+deb12u1~bpo11+1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.4-1+deb12u1
Actualiza a 1.14.4-1+deb12u1
flatpak Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.6-1
Actualiza a 1.14.6-1
flatpak Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.6-1
Actualiza a 1.14.6-1
flatpak Ubuntu:Pro:18.04:LTS
- Versiones
- 0.8.7-5
- 0.10.0-1
- 0.10.0-2
- 0.10.1-1
- 0.10.2-1
- 0.10.2.1-1
- 0.10.2.1-2
- 0.10.3-1
- 0.11.1-0ubuntu1
- 0.11.3-2
- 0.11.3-3
- 0.11.7-0ubuntu0.1
- 1.0.1-0ubuntu0.1
- 1.0.6-0ubuntu0.1
- 1.0.7-0ubuntu0.18.04.1
- 1.0.8-0ubuntu0.18.04.1
- 1.0.9-0ubuntu0.1
- 1.0.9-0ubuntu0.2
- 1.0.9-0ubuntu0.3
- 1.0.9-0ubuntu0.4
- 1.0.9-0ubuntu0.4+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
flatpak Ubuntu:Pro:20.04:LTS
- Versiones
- 1.4.3-1
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.6.3-1
- 1.6.5-0ubuntu0.1
- 1.6.5-0ubuntu0.2
- 1.6.5-0ubuntu0.3
- 1.6.5-0ubuntu0.4
- 1.6.5-0ubuntu0.5
- 1.6.5-0ubuntu0.5+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
flatpak Ubuntu:Pro:22.04:LTS
- Versiones
- 1.10.2-3
- 1.12.2-1
- 1.12.2-2
- 1.12.3-1
- 1.12.4-1
- 1.12.5-1
- 1.12.6-1
- 1.12.7-1
- 1.12.7-1ubuntu0.1
- 1.12.7-1ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
flatpak Ubuntu:24.04:LTS
- Versiones
- 1.14.4-2
- 1.14.5-1
- 1.14.5-1build1
- 1.14.5-1build4
- 1.14.5-1build5
- 1.14.5-1build6
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.6-1
Actualiza a 1.14.6-1
Fuentes originales
- https://github.com/flatpak/flatpak/security/advisories/GHSA-phv6-cpc2-2fgj
- https://github.com/flatpak/flatpak/commit/72016e3fce8fcbeab707daf4f1a02b931fcc004d
- https://github.com/flatpak/flatpak/commit/81abe2a37d363f5099c3d0bdcd0caad6efc5bf97
- https://github.com/flatpak/flatpak/commit/b7c1a558e58aaeb1d007d29529bbb270dc4ff11e
- https://github.com/flatpak/flatpak/commit/bbab7ed1e672356d1a78b422462b210e8e875931
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZFNSCFJVMAQK5AF55JBN7OSJP3CREDBD/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/IB6VQAF5S2YOBULDHPUKPOEIKONOP5KO/
- http://www.openwall.com/lists/oss-security/2024/04/18/5
- https://nvd.nist.gov/vuln/detail/CVE-2024-32462