p PatchFirst

CVE-2024-34064

CVE-2024-34064 · Jinja vulnerable to HTML attribute injection when passing user input as keys to xmlattr filter

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Jinja is an extensible templating engine. The `xmlattr` filter in affected versions of Jinja accepts keys containing non-attribute characters. XML/HTML attributes cannot contain spaces, `/`, `>`, or `=`, as each would then be interpreted as starting a separate attribute. If an application accepts keys (as opposed to only values) as user input, and renders these in pages that other users see as well, an attacker could use this to inject other attributes and perform XSS. The fix for CVE-2024-22195 only addressed spaces but not other characters. Accepting keys as user input is now explicitly considered an unintended use case of the `xmlattr` filter, and code that does so without otherwise validating the input should be flagged as insecure, regardless of Jinja version. Accepting _values_ as user input continues to be safe. This vulnerability is fixed in 3.1.4.

CVSS 5.4 · Media · EPSS 1,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • jinja

    Versiones
    • < 3.1.4: Afectada

    Sin corrección publicada

  • jinja2 Debian:12

    Versiones
    • 3.1.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.2-1+deb12u1

    Actualiza a 3.1.2-1+deb12u1

  • jinja2 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.3-1.1

    Actualiza a 3.1.3-1.1

  • jinja2 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.3-1.1

    Actualiza a 3.1.3-1.1

  • jinja2 PyPI

    Versiones
    • 2.0
    • 2.0rc1
    • 2.1
    • 2.1.1
    • 2.10
    • 2.10.1
    • 2.10.2
    • 2.10.3
    • 2.11.0
    • 2.11.1
    • 2.11.2
    • 2.11.3
    • 2.2
    • 2.2.1
    • 2.3
    • 2.3.1
    • 2.4
    • 2.4.1
    • 2.5
    • 2.5.1
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    • 2.6
    • 2.7
    • 2.7.1
    • 2.7.2
    • 2.7.3
    • 2.8
    • 2.8.1
    • 2.9
    • 2.9.1
    • 2.9.2
    • 2.9.3
    • 2.9.4
    • 2.9.5
    • 2.9.6
    • 3.0.0
    • 3.0.0a1
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.1.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.4

    Actualiza a 3.1.4

  • jinja2 Ubuntu:Pro:14.04:LTS

    Versiones
    • 2.7-3
    • 2.7.1-1
    • 2.7.2-1
    • 2.7.2-2
    • 2.7.2-2ubuntu0.1~esm1
    • 2.7.2-2ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.7.2-2ubuntu0.1~esm3

    Actualiza a 2.7.2-2ubuntu0.1~esm3

  • jinja2 Ubuntu:Pro:16.04:LTS

    Versiones
    • 2.8-1
    • 2.8-1ubuntu0.1
    • 2.8-1ubuntu0.1+esm1
    • 2.8-1ubuntu0.1+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.8-1ubuntu0.1+esm3

    Actualiza a 2.8-1ubuntu0.1+esm3

  • jinja2 Ubuntu:Pro:18.04:LTS

    Versiones
    • 2.9.6-1
    • 2.10-1
    • 2.10-1ubuntu0.18.04.1
    • 2.10-1ubuntu0.18.04.1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.10-1ubuntu0.18.04.1+esm2

    Actualiza a 2.10-1ubuntu0.18.04.1+esm2

  • jinja2 Ubuntu:20.04:LTS

    Versiones
    • 2.10-2ubuntu1
    • 2.10-2ubuntu2
    • 2.10.1-1ubuntu1
    • 2.10.1-2
    • 2.10.1-2ubuntu0.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.10.1-2ubuntu0.3

    Actualiza a 2.10.1-2ubuntu0.3

  • jinja2 Ubuntu:22.04:LTS

    Versiones
    • 2.11.3-1
    • 3.0.1-2
    • 3.0.3-1
    • 3.0.3-1ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.3-1ubuntu0.2

    Actualiza a 3.0.3-1ubuntu0.2

  • jinja2 Ubuntu:24.04:LTS

    Versiones
    • 3.1.2-1
    • 3.1.2-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.1.2-1ubuntu1.1

    Actualiza a 3.1.2-1ubuntu1.1

Fuentes originales

Comprueba tu servidor →