CVE-2024-34070
CVE-2024-34070 · Froxlor Vulnerable to Blind XSS Leading to Froxlor Application Compromise
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Froxlor is open source server administration software. Prior to 2.1.9, a Stored Blind Cross-Site Scripting (XSS) vulnerability was identified in the Failed Login Attempts Logging Feature of the Froxlor Application. An unauthenticated User can inject malicious scripts in the loginname parameter on the Login attempt, which will then be executed when viewed by the Administrator in the System Logs. By exploiting this vulnerability, the attacker can perform various malicious actions such as forcing the Administrator to execute actions without their knowledge or consent. For instance, the attacker can force the Administrator to add a new administrator controlled by the attacker, thereby giving the attacker full control over the application. This vulnerability is fixed in 2.1.9.
CVSS 9.7 · Crítica · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
froxlor
- Versiones
- < 2.1.9: Afectada
Sin corrección publicada
froxlor/froxlor Packagist
- Versiones
- 0.10.0
- 0.10.0-rc1
- 0.10.0-rc2
- 0.10.1
- 0.10.10
- 0.10.11
- 0.10.12
- 0.10.13
- 0.10.14
- 0.10.15
- 0.10.16
- 0.10.17
- 0.10.18
- 0.10.19
- 0.10.2
- 0.10.20
- 0.10.21
- 0.10.22
- 0.10.23
- 0.10.23.1
- 0.10.24
- 0.10.25
- 0.10.26
- 0.10.27
- 0.10.28
- 0.10.29
- 0.10.29.1
- 0.10.3
- 0.10.30
- 0.10.31
- 0.10.32
- 0.10.33
- 0.10.34
- 0.10.34.1
- 0.10.35
- 0.10.35.1
- 0.10.36
- 0.10.37
- 0.10.38
- 0.10.38.1
- 0.10.38.2
- 0.10.38.3
- 0.10.4
- 0.10.5
- 0.10.6
- 0.10.7
- 0.10.8
- 0.10.9
- 2.0.0
- 2.0.1
- 2.0.10
- 2.0.11
- 2.0.12
- 2.0.13
- 2.0.14
- 2.0.15
- 2.0.16
- 2.0.17
- 2.0.18
- 2.0.19
- 2.0.2
- 2.0.20
- 2.0.21
- 2.0.22
- 2.0.23
- 2.0.24
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.0.8
- 2.0.9
- 2.1.0
- 2.1.0-beta1
- 2.1.0-beta2
- 2.1.0-rc1
- 2.1.0-rc2
- 2.1.0-rc3
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.1.7
- 2.1.8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.9
Actualiza a 2.1.9