p PatchFirst

CVE-2024-34715

CVE-2024-34715 · Partial Password Exposure Vulnerability in Fides Webserver Logs

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Fides is an open-source privacy engineering platform. The Fides webserver requires a connection to a hosted PostgreSQL database for persistent storage of application data. If the password used by the webserver for this database connection includes special characters such as `@` and `$`, webserver startup fails and the part of the password following the special character is exposed in webserver error logs. This is caused by improper escaping of the SQLAlchemy password string. As a result users are subject to a partial exposure of hosted database password in webserver logs. The vulnerability has been patched in Fides version `2.37.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no known workarounds for this vulnerability.

CVSS 2.3 · Baja · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • fides

    Versiones
    • < 2.37.0: Afectada

    Sin corrección publicada

  • ethyca-fides PyPI

    Versiones
    • 1.9.9
    • 2.0.0
    • 2.1.0
    • 2.10.0
    • 2.11.0
    • 2.12.0
    • 2.12.1
    • 2.13.0
    • 2.14.0
    • 2.14.1
    • 2.14.2
    • 2.15.0
    • 2.15.1
    • 2.16.0
    • 2.17.0
    • 2.17.1
    • 2.18.0
    • 2.19.0
    • 2.19.1
    • 2.2.0
    • 2.2.1
    • 2.2.2
    • 2.20.0
    • 2.20.1
    • 2.20.2
    • 2.21.0
    • 2.22.0
    • 2.22.1
    • 2.23.0
    • 2.23.1
    • 2.23.2
    • 2.23.3
    • 2.24.0
    • 2.24.1
    • 2.25.0
    • 2.26.0
    • 2.26.3
    • 2.27.0
    • 2.28.0
    • 2.29.0
    • 2.3.0
    • 2.3.1
    • 2.30.0
    • 2.30.1
    • 2.31.0
    • 2.32.0
    • 2.33.0
    • 2.33.1
    • 2.34.0
    • 2.35.0
    • 2.35.1
    • 2.36.0
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.6.0
    • 2.6.1
    • 2.6.2
    • 2.6.3
    • 2.6.4
    • 2.6.5
    • 2.6.6
    • 2.7.0
    • 2.7.1
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.9.0
    • 2.9.1
    • 2.9.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.37.0

    Actualiza a 2.37.0

Fuentes originales

Comprueba tu servidor →