CVE-2024-38537
CVE-2024-38537 · Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Fides is an open-source privacy engineering platform. `fides.js`, a client-side script used to interact with the consent management features of Fides, used the `polyfill.io` domain in a very limited edge case, when it detected a legacy browser such as IE11 that did not support the fetch standard. Therefore it was possible for users of legacy, pre-2017 browsers who navigate to a page serving `fides.js` to download and execute malicious scripts from the `polyfill.io` domain when the domain was compromised and serving malware. No exploitation of `fides.js` via `polyfill.io` has been identified as of time of publication. The vulnerability has been patched in Fides version `2.39.1`. Users are advised to upgrade to this version or later to secure their systems against this threat. On Thursday, June 27, 2024, Cloudflare and Namecheap intervened at a domain level to ensure `polyfill.io` and its subdomains could not resolve to the compromised service, rendering this vulnerability unexploitable. Prior to the domain level intervention, there were no server-side workarounds and the confidentiality, integrity, and availability impacts of this vulnerability were high. Clients could ensure they were not affected by using a modern browser that supported the fetch standard.
CVSS 0.0 · Baja · EPSS 1,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
fides
- Versiones
- < 2.39.1: Afectada
Sin corrección publicada
ethyca-fides PyPI
- Versiones
- 1.9.9
- 2.0.0
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.14.0
- 2.14.1
- 2.14.2
- 2.15.0
- 2.15.1
- 2.16.0
- 2.17.0
- 2.17.1
- 2.18.0
- 2.19.0
- 2.19.1
- 2.2.0
- 2.2.1
- 2.2.2
- 2.20.0
- 2.20.1
- 2.20.2
- 2.21.0
- 2.22.0
- 2.22.1
- 2.23.0
- 2.23.1
- 2.23.2
- 2.23.3
- 2.24.0
- 2.24.1
- 2.25.0
- 2.26.0
- 2.26.3
- 2.27.0
- 2.28.0
- 2.29.0
- 2.3.0
- 2.3.1
- 2.30.0
- 2.30.1
- 2.31.0
- 2.32.0
- 2.33.0
- 2.33.1
- 2.34.0
- 2.35.0
- 2.35.1
- 2.36.0
- 2.37.0
- 2.38.0
- 2.38.1
- 2.39.0
- 2.4.0
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.9.0
- 2.9.1
- 2.9.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.39.1
Actualiza a 2.39.1
Fuentes originales
- https://github.com/ethyca/fides/security/advisories/GHSA-cvw4-c69g-7v7m
- https://github.com/ethyca/fides/pull/5026
- https://github.com/ethyca/fides/commit/868c4d629760572192bd61db34f5a4458ed12005
- https://fetch.spec.whatwg.org
- https://sansec.io/research/polyfill-supply-chain-attack
- https://nvd.nist.gov/vuln/detail/CVE-2024-38537