CVE-2024-42356
CVE-2024-42356 · Shopware vulnerable to Server Side Template Injection in Twig using Context functions
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Shopware is an open commerce platform. Prior to versions 6.6.5.1 and 6.5.8.13, the `context` variable is injected into almost any Twig Template and allows to access to current language, currency information. The context object allows also to switch for a short time the scope of the Context as a helper with a callable function. The function can be called also from Twig and as the second parameter allows any callable, it's possible to call from Twig any statically callable PHP function/method. It's not possible as customer to provide any Twig code, the attacker would require access to Administration to exploit it using Mail templates or using App Scripts. Update to Shopware 6.6.5.1 or 6.5.8.13 to receive a patch. For older versions of 6.1, 6.2, 6.3 and 6.4 corresponding security measures are also available via a plugin.
CVSS 8.3 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
shopware
- Versiones
- <= 6.5.8.12: Afectada
- >= 6.6.0.0, <= 6.6.5.0: Afectada
Sin corrección publicada
shopware/core Packagist
- Versiones
- 6.3.0.0
- 6.3.0.1
- 6.3.0.2
- 6.3.1.0
- 6.3.1.1
- 6.3.2.0
- 6.3.2.1
- 6.3.3.0
- 6.3.3.1
- 6.3.4.0
- 6.3.4.1
- 6.3.5.0
- 6.3.5.1
- 6.3.5.2
- 6.3.5.3
- 6.3.5.4
- 6.4.0.0
- 6.4.0.0-RC1
- 6.4.1.0
- 6.4.1.1
- 6.4.1.2
- 6.4.10.0
- 6.4.10.1
- 6.4.11.0
- 6.4.11.1
- 6.4.12.0
- 6.4.13.0
- 6.4.14.0
- 6.4.15.0
- 6.4.15.1
- 6.4.15.2
- 6.4.16.0
- 6.4.16.1
- 6.4.17.0
- 6.4.17.1
- 6.4.17.2
- 6.4.18.0
- 6.4.18.1
- 6.4.19.0
- 6.4.2.0
- 6.4.2.1
- 6.4.20.0
- 6.4.20.1
- 6.4.20.2
- 6.4.3.0
- 6.4.3.1
- 6.4.4.0
- 6.4.4.1
- 6.4.5.0
- 6.4.5.1
- 6.4.6.0
- 6.4.6.1
- 6.4.7.0
- 6.4.8.0
- 6.4.8.1
- 6.4.8.2
- 6.4.9.0
- 6.5.0.0
- 6.5.0.0-rc1
- 6.5.0.0-rc2
- 6.5.0.0-rc3
- 6.5.0.0-rc4
- v6.0.0+ea2
- v6.1.0
- v6.1.0-rc1
- v6.1.0-rc2
- v6.1.0-rc3
- v6.1.0-rc4
- v6.1.1
- v6.1.2
- v6.1.3
- v6.1.4
- v6.1.5
- v6.1.6
- v6.2.0
- v6.2.0-RC1
- v6.2.1
- v6.2.2
- v6.2.3
- v6.5.1.0
- v6.5.1.1
- v6.5.2.0
- v6.5.2.1
- v6.5.3.0
- v6.5.3.1
- v6.5.3.2
- v6.5.3.3
- v6.5.4.0
- v6.5.4.1
- v6.5.5.0
- v6.5.5.1
- v6.5.5.2
- v6.5.6.0
- v6.5.6.1
- v6.5.7.0
- v6.5.7.1
- v6.5.7.2
- v6.5.7.3
- v6.5.7.4
- v6.5.8.0
- v6.5.8.1
- v6.5.8.10
- v6.5.8.11
- v6.5.8.12
- v6.5.8.2
- v6.5.8.3
- v6.5.8.4
- v6.5.8.5
- v6.5.8.6
- v6.5.8.7
- v6.5.8.8
- v6.5.8.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.5.8.13
Actualiza a 6.5.8.13
shopware/platform Packagist
- Versiones
- 6.3.0.0
- 6.3.0.1
- 6.3.0.2
- 6.3.1.0
- 6.3.1.1
- 6.3.2.0
- 6.3.2.1
- 6.3.3.0
- 6.3.3.1
- 6.3.4.0
- 6.3.4.1
- 6.3.5.0
- 6.3.5.1
- 6.3.5.2
- 6.3.5.3
- 6.3.5.4
- 6.4.0.0
- 6.4.0.0-RC1
- 6.4.1.0
- 6.4.1.1
- 6.4.1.2
- 6.4.10.0
- 6.4.10.1
- 6.4.11.0
- 6.4.11.1
- 6.4.12.0
- 6.4.13.0
- 6.4.14.0
- 6.4.15.0
- 6.4.15.1
- 6.4.15.2
- 6.4.16.0
- 6.4.16.1
- 6.4.17.0
- 6.4.17.1
- 6.4.17.2
- 6.4.18.0
- 6.4.18.1
- 6.4.19.0
- 6.4.2.0
- 6.4.2.1
- 6.4.20.0
- 6.4.20.1
- 6.4.20.2
- 6.4.3.0
- 6.4.3.1
- 6.4.4.0
- 6.4.4.1
- 6.4.5.0
- 6.4.5.1
- 6.4.6.0
- 6.4.6.1
- 6.4.7.0
- 6.4.8.0
- 6.4.8.1
- 6.4.8.2
- 6.4.9.0
- 6.5.0.0
- 6.5.0.0-rc1
- 6.5.0.0-rc2
- 6.5.0.0-rc3
- 6.5.0.0-rc4
- v6.0.0+ea2
- v6.1.0
- v6.1.0-rc1
- v6.1.0-rc2
- v6.1.0-rc3
- v6.1.0-rc4
- v6.1.1
- v6.1.2
- v6.1.3
- v6.1.4
- v6.1.5
- v6.1.6
- v6.2.0
- v6.2.0-RC1
- v6.2.1
- v6.2.2
- v6.2.3
- v6.5.1.0
- v6.5.1.1
- v6.5.2.0
- v6.5.2.1
- v6.5.3.0
- v6.5.3.1
- v6.5.3.2
- v6.5.3.3
- v6.5.4.0
- v6.5.4.1
- v6.5.5.0
- v6.5.5.1
- v6.5.5.2
- v6.5.6.0
- v6.5.6.1
- v6.5.7.0
- v6.5.7.1
- v6.5.7.2
- v6.5.7.3
- v6.5.7.4
- v6.5.8.0
- v6.5.8.1
- v6.5.8.10
- v6.5.8.11
- v6.5.8.12
- v6.5.8.2
- v6.5.8.3
- v6.5.8.4
- v6.5.8.5
- v6.5.8.6
- v6.5.8.7
- v6.5.8.8
- v6.5.8.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.5.8.13
Actualiza a 6.5.8.13
shopware/platform Packagist
- Versiones
- v6.6.0.0
- v6.6.0.1
- v6.6.0.2
- v6.6.0.3
- v6.6.1.0
- v6.6.1.1
- v6.6.1.2
- v6.6.2.0
- v6.6.3.0
- v6.6.3.1
- v6.6.4.0
- v6.6.4.1
- v6.6.5.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.6.0.0, < 6.6.5.1
Actualiza a 6.6.5.1
shopware/core Packagist
- Versiones
- v6.6.0.0
- v6.6.0.1
- v6.6.0.2
- v6.6.0.3
- v6.6.1.0
- v6.6.1.1
- v6.6.1.2
- v6.6.2.0
- v6.6.3.0
- v6.6.3.1
- v6.6.4.0
- v6.6.4.1
- v6.6.5.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.6.0.0, < 6.6.5.1
Actualiza a 6.6.5.1
Fuentes originales
- https://github.com/shopware/shopware/security/advisories/GHSA-35jp-8cgg-p4wj
- https://github.com/shopware/core/commit/04183e0c02af3b404eb7d52c683734bfe0595038
- https://github.com/shopware/core/commit/a784aa1cec0624e36e0ee4d41aeebaed40e0442f
- https://github.com/shopware/shopware/commit/8504ba7e56e53add6a1d5b9d45015e3d899cd0ac
- https://github.com/shopware/shopware/commit/e43423bcc93c618c3036f94c12aa29514da8cf2e
- https://nvd.nist.gov/vuln/detail/CVE-2024-42356