p PatchFirst

CVE-2024-43795

CVE-2024-43795 · OpenC3 COSMOS vulnerable to cross-site scripting in Login functionality (`GHSL-2024-128`)

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

OpenC3 COSMOS provides the functionality needed to send commands to and receive data from one or more embedded systems. The login functionality contains a reflected cross-site scripting (XSS) vulnerability. This vulnerability is fixed in 5.19.0. Note: This CVE only affects Open Source Edition, and not OpenC3 COSMOS Enterprise Edition.

CVSS 5.1 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python · node

Productos y versiones afectados

  • cosmos

    Versiones
    • < 5.19.0: Afectada

    Sin corrección publicada

  • openc3 RubyGems

    Versiones
    • 5.0.10
    • 5.0.11
    • 5.0.6
    • 5.0.7
    • 5.0.8
    • 5.0.9
    • 5.1.0
    • 5.1.1
    • 5.10.0
    • 5.10.1
    • 5.11.0
    • 5.11.1
    • 5.11.2
    • 5.11.3
    • 5.12.0
    • 5.13.0
    • 5.14.0
    • 5.14.1
    • 5.14.2
    • 5.15.0
    • 5.15.1
    • 5.15.2
    • 5.16.0
    • 5.16.1
    • 5.16.2
    • 5.17.0
    • 5.17.1
    • 5.18.0
    • 5.2.0
    • 5.3.0
    • 5.4.0
    • 5.4.1
    • 5.4.2
    • 5.4.3.pre.beta0
    • 5.5.0
    • 5.5.0.pre.beta0
    • 5.5.1
    • 5.5.2
    • 5.5.2.pre.beta0
    • 5.6.0
    • 5.6.1
    • 5.7.0
    • 5.7.2
    • 5.8.0
    • 5.8.1
    • 5.9.0
    • 5.9.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.19.0

    Actualiza a 5.19.0

  • @openc3/tool-common npm

    Intervalos de versiones afectados
    • SEMVER: < 5.19.0

    Actualiza a 5.19.0

  • openc3 PyPI

    Versiones
    • 0.1.0
    • 5.10.0
    • 5.10.1
    • 5.11.0
    • 5.11.1
    • 5.11.2
    • 5.11.3
    • 5.12.0
    • 5.13.0
    • 5.14.0
    • 5.14.1
    • 5.14.2
    • 5.15.0
    • 5.15.1
    • 5.15.2
    • 5.16.0
    • 5.16.1
    • 5.16.2
    • 5.17.0
    • 5.17.1
    • 5.18.0
    • 5.9.2b0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.19.0

    Actualiza a 5.19.0

  • openc3 PyPI

    Versiones
    • 0.1.0
    • 5.10.0
    • 5.10.1
    • 5.11.0
    • 5.11.1
    • 5.11.2
    • 5.11.3
    • 5.12.0
    • 5.13.0
    • 5.14.0
    • 5.14.1
    • 5.14.2
    • 5.15.0
    • 5.15.1
    • 5.15.2
    • 5.16.0
    • 5.16.1
    • 5.16.2
    • 5.17.0
    • 5.17.1
    • 5.18.0
    • 5.9.2b0
    Intervalos de versiones afectados
    • GIT: < 762d7e0e93bdc2f340b1e42acccedc78994a576e
    • ECOSYSTEM: < 5.19.0

    Actualiza a 5.19.0

Fuentes originales

Comprueba tu servidor →