CVE-2024-45052
CVE-2024-45052 · Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Fides is an open-source privacy engineering platform. Prior to version 2.44.0, a timing-based username enumeration vulnerability exists in Fides Webserver authentication. This vulnerability allows an unauthenticated attacker to determine the existence of valid usernames by analyzing the time it takes for the server to respond to login requests. The discrepancy in response times between valid and invalid usernames can be leveraged to enumerate users on the system. This vulnerability enables a timing-based username enumeration attack. An attacker can systematically guess and verify which usernames are valid by measuring the server's response time to authentication requests. This information can be used to conduct further attacks on authentication such as password brute-forcing and credential stuffing. The vulnerability has been patched in Fides version `2.44.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no workarounds.
CVSS 5.3 · Media · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
fides
- Versiones
- < 2.44.0: Afectada
Sin corrección publicada
ethyca-fides PyPI
- Versiones
- 1.9.9
- 2.0.0
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.14.0
- 2.14.1
- 2.14.2
- 2.15.0
- 2.15.1
- 2.16.0
- 2.17.0
- 2.17.1
- 2.18.0
- 2.19.0
- 2.19.1
- 2.2.0
- 2.2.1
- 2.2.2
- 2.20.0
- 2.20.1
- 2.20.2
- 2.21.0
- 2.22.0
- 2.22.1
- 2.23.0
- 2.23.1
- 2.23.2
- 2.23.3
- 2.24.0
- 2.24.1
- 2.25.0
- 2.26.0
- 2.26.3
- 2.27.0
- 2.28.0
- 2.29.0
- 2.3.0
- 2.3.1
- 2.30.0
- 2.30.1
- 2.31.0
- 2.32.0
- 2.33.0
- 2.33.1
- 2.34.0
- 2.35.0
- 2.35.1
- 2.36.0
- 2.37.0
- 2.38.0
- 2.38.1
- 2.39.0
- 2.39.1
- 2.39.2
- 2.4.0
- 2.40.0
- 2.41.0
- 2.42.0
- 2.42.1
- 2.43.0
- 2.43.2
- 2.5.0
- 2.5.1
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.7.0
- 2.7.1
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.9.0
- 2.9.1
- 2.9.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.44.0
Actualiza a 2.44.0