CVE-2024-45296
CVE-2024-45296 · path-to-regexp outputs backtracking regular expressions
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
path-to-regexp turns path strings into a regular expressions. In certain cases, path-to-regexp will output a regular expression that can be exploited to cause poor performance. Because JavaScript is single threaded and regex matching runs on the main thread, poor performance will block the event loop and lead to a DoS. The bad regular expression is generated any time you have two parameters within a single segment, separated by something that is not a period (.). For users of 0.1, upgrade to 0.1.10. All other users should upgrade to 8.0.0.
CVSS 7.5 · Alta · EPSS 0,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
path-to-regexp
- Versiones
- < 0.1.10: Afectada
- >= 0.2.0, < 8.0.0: Afectada
Sin corrección publicada
node-path-to-regexp Debian:12
- Versiones
- 6.2.1-1
- 6.3.0-1
- 8.3.0-1
- 8.4.0-1
- 8.4.1-1
- 8.4.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-path-to-regexp Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.3.0-1
Actualiza a 6.3.0-1
node-path-to-regexp Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.3.0-1
Actualiza a 6.3.0-1
path-to-regexp npm
- Intervalos de versiones afectados
- SEMVER: < 0.1.13
Actualiza a 0.1.13
path-to-regexp npm
- Intervalos de versiones afectados
- SEMVER: ≥ 0.2.0, < 1.9.0
Actualiza a 1.9.0
path-to-regexp npm
- Intervalos de versiones afectados
- SEMVER: < 0.1.10
Actualiza a 0.1.10
path-to-regexp npm
- Intervalos de versiones afectados
- SEMVER: ≥ 7.0.0, < 8.0.0
Actualiza a 8.0.0
path-to-regexp npm
- Intervalos de versiones afectados
- SEMVER: ≥ 2.0.0, < 3.3.0
Actualiza a 3.3.0
path-to-regexp npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.0, < 6.3.0
Actualiza a 6.3.0
node-path-to-regexp Ubuntu:Pro:16.04:LTS
- Versiones
- 1.0.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.1-1ubuntu0.16.04.1~esm1
Actualiza a 1.0.1-1ubuntu0.16.04.1~esm1
node-path-to-regexp Ubuntu:Pro:18.04:LTS
- Versiones
- 1.0.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.1-1ubuntu0.18.04.1~esm1
Actualiza a 1.0.1-1ubuntu0.18.04.1~esm1
node-path-to-regexp Ubuntu:Pro:20.04:LTS
- Versiones
- 3.0.0-2
- 3.1.0-1
- 6.1.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.1.0-2ubuntu0.1~esm1
Actualiza a 6.1.0-2ubuntu0.1~esm1
node-path-to-regexp Ubuntu:Pro:22.04:LTS
- Versiones
- 6.2.0-1
- 6.2.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.2.0-2ubuntu0.1~esm1
Actualiza a 6.2.0-2ubuntu0.1~esm1
node-path-to-regexp Ubuntu:Pro:24.04:LTS
- Versiones
- 6.2.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 6.2.1-1ubuntu0.1~esm1
Actualiza a 6.2.1-1ubuntu0.1~esm1
node-express Ubuntu:25.10
- Versiones
- 4.21.0+~cs8.36.26-2
- 4.21.2+~cs8.36.27-1
- 4.21.2+~cs8.36.27-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-express Ubuntu:26.10
- Versiones
- 5.1.0+~cs12.3.3-1build1
- 5.2.1+~cs12.3.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-express Ubuntu:26.04:LTS
- Versiones
- 4.21.2+~cs8.36.27-2
- 4.21.2+~cs8.36.27-3
- 5.1.0+~cs12.3.3-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/pillarjs/path-to-regexp/security/advisories/GHSA-9wv6-86v2-598j
- https://github.com/pillarjs/path-to-regexp/commit/29b96b4a1de52824e1ca0f49a701183cc4ed476f
- https://github.com/pillarjs/path-to-regexp/commit/60f2121e9b66b7b622cc01080df0aabda9eedee6
- https://security.netapp.com/advisory/ntap-20250124-0001/
- https://nvd.nist.gov/vuln/detail/CVE-2024-45296