CVE-2024-46981
CVE-2024-46981 · Redis' Lua library commands may lead to remote code execution
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Redis is an open source, in-memory database that persists on disk. An authenticated user may use a specially crafted Lua script to manipulate the garbage collector and potentially lead to remote code execution. The problem is fixed in 7.4.2, 7.2.7, and 6.2.17. An additional workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.
CVSS 7.0 · Alta · EPSS 8,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
redis
- Versiones
- >= 7.4.0, < 7.4.2: Afectada
- >= 7.2.0, < 7.2.7: Afectada
- < 6.2.17: Afectada
Sin corrección publicada
redict Debian:14
- Versiones
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- 7.3.1+ds-1
- 7.3.2+ds-1~bpo12+1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.3.2+ds-1
Actualiza a 7.3.2+ds-1
redis Debian:12
- Versiones
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1~deb12u1
- 5:7.0.15-1~deb12u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-1~deb12u3
Actualiza a 5:7.0.15-1~deb12u3
redis Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-3
Actualiza a 5:7.0.15-3
redis Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-3
Actualiza a 5:7.0.15-3
valkey Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.0.2+dfsg1-1
Actualiza a 8.0.2+dfsg1-1
valkey Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.0.2+dfsg1-1
Actualiza a 8.0.2+dfsg1-1
redis Ubuntu:Pro:14.04:LTS
- Versiones
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- 2:2.8.4-2ubuntu0.2+esm2
- 2:2.8.4-2ubuntu0.2+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:2.8.4-2ubuntu0.2+esm4
Actualiza a 2:2.8.4-2ubuntu0.2+esm4
redis Ubuntu:Pro:16.04:LTS
- Versiones
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- 2:3.0.6-1ubuntu0.4+esm1
- 2:3.0.6-1ubuntu0.4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:3.0.6-1ubuntu0.4+esm3
Actualiza a 2:3.0.6-1ubuntu0.4+esm3
redis Ubuntu:Pro:18.04:LTS
- Versiones
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- 5:4.0.9-1ubuntu0.2+esm3
- 5:4.0.9-1ubuntu0.2+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:4.0.9-1ubuntu0.2+esm5
Actualiza a 5:4.0.9-1ubuntu0.2+esm5
redis Ubuntu:Pro:20.04:LTS
- Versiones
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- 5:5.0.7-2ubuntu0.1+esm1
- 5:5.0.7-2ubuntu0.1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:5.0.7-2ubuntu0.1+esm3
Actualiza a 5:5.0.7-2ubuntu0.1+esm3
redis Ubuntu:Pro:22.04:LTS
- Versiones
- 5:6.0.15-1
- 5:6.0.16-1
- 5:6.0.16-1build1
- 5:6.0.16-1ubuntu1
- 5:6.0.16-1ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:6.0.16-1ubuntu1+esm2
Actualiza a 5:6.0.16-1ubuntu1+esm2
redis Ubuntu:24.04:LTS
- Versiones
- 5:7.0.12-1
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1
- 5:7.0.15-1build1
- 5:7.0.15-1build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 5:7.0.15-1ubuntu0.24.04.1
Actualiza a 5:7.0.15-1ubuntu0.24.04.1
valkey Ubuntu:24.04:LTS
- Versiones
- 7.2.5+dfsg1-2ubuntu4~24.04.1
- 7.2.7+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.2.8+dfsg1-0ubuntu0.24.04.2
Actualiza a 7.2.8+dfsg1-0ubuntu0.24.04.2
redict Ubuntu:25.10
- Versiones
- 7.3.2+ds-1
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.5+ds-1ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
redict Ubuntu:26.10
- Versiones
- 7.3.6+ds-1
- 7.3.6+ds-2
- 7.3.6+ds-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
redict Ubuntu:26.04:LTS
- Versiones
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.6+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/redis/redis/security/advisories/GHSA-39h2-x6c4-6w4c
- https://github.com/redis/redis/releases/tag/6.2.17
- https://github.com/redis/redis/releases/tag/7.2.7
- https://github.com/redis/redis/releases/tag/7.4.2
- https://lists.debian.org/debian-lts-announce/2025/01/msg00018.html
- https://www.vicarius.io/vsociety/posts/cve-2024-46981-detect-redis-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2024-46981-mitigate-redis-vulnerability
- https://nvd.nist.gov/vuln/detail/CVE-2024-46981