p PatchFirst

CVE-2024-47544

CVE-2024-47544 · GHSL-2024-238: GStreamer has NULL-pointer dereferences in MP4/MOV demuxer CENC handling

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

GStreamer is a library for constructing graphs of media-handling components. The function qtdemux_parse_sbgp in qtdemux.c is affected by a null dereference vulnerability. This vulnerability is fixed in 1.24.10.

CVSS 6.8 · Media · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • gstreamer

    Versiones
    • < 1.24.10: Afectada

    Sin corrección publicada

  • gst-plugins-good1.0 Debian:12

    Versiones
    • 1.22.0-5
    • 1.22.0-5+deb12u1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.22.0-5+deb12u2

    Actualiza a 1.22.0-5+deb12u2

  • gst-plugins-good1.0 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.24.10-1

    Actualiza a 1.24.10-1

  • gst-plugins-good1.0 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.24.10-1

    Actualiza a 1.24.10-1

  • gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    • 1.8.3-1ubuntu0.4
    • 1.8.3-1ubuntu0.5
    • 1.8.3-1ubuntu0.5+esm1
    • 1.8.3-1ubuntu0.5+esm2
    • 1.8.3-1ubuntu0.5+esm3
    • 1.8.3-1ubuntu0.5+esm4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • gst-plugins-good0.10 Ubuntu:16.04:LTS

    Versiones
    • 0.10.31-3+nmu4ubuntu2~gcc5.1
    • 0.10.31-3+nmu4ubuntu2.16.04.1
    • 0.10.31-3+nmu4ubuntu2.16.04.2
    • 0.10.31-3+nmu4ubuntu2.16.04.3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.12.3-1ubuntu1
    • 1.12.4-1ubuntu1
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.2
    • 1.14.5-0ubuntu1~18.04.3
    • 1.14.5-0ubuntu1~18.04.3+esm1
    • 1.14.5-0ubuntu1~18.04.3+esm2
    • 1.14.5-0ubuntu1~18.04.3+esm3
    • 1.14.5-0ubuntu1~18.04.3+esm4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • gst-plugins-good1.0 Ubuntu:20.04:LTS

    Versiones
    • 1.16.1-1ubuntu1
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    • 1.16.2-1ubuntu2.1
    • 1.16.3-0ubuntu1
    • 1.16.3-0ubuntu1.1
    • 1.16.3-0ubuntu1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.16.3-0ubuntu1.3

    Actualiza a 1.16.3-0ubuntu1.3

  • gst-plugins-good1.0 Ubuntu:22.04:LTS

    Versiones
    • 1.18.5-1ubuntu2
    • 1.18.5-1ubuntu3
    • 1.20.0-2ubuntu1
    • 1.20.1-1ubuntu1
    • 1.20.3-0ubuntu1
    • 1.20.3-0ubuntu1.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.20.3-0ubuntu1.3

    Actualiza a 1.20.3-0ubuntu1.3

  • gst-plugins-good1.0 Ubuntu:24.04:LTS

    Versiones
    • 1.22.6-1ubuntu1
    • 1.22.6-1ubuntu2
    • 1.22.8-3ubuntu1
    • 1.22.9-1ubuntu1
    • 1.24.0-1ubuntu5
    • 1.24.0-1ubuntu7
    • 1.24.1-2ubuntu1
    • 1.24.2-1ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.24.2-1ubuntu1.1

    Actualiza a 1.24.2-1ubuntu1.1

Fuentes originales

Comprueba tu servidor →