CVE-2024-47615
CVE-2024-47615 · GHSL-2024-117: GStreamer has an out-of-bounds write in Ogg demuxer
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
GStreamer is a library for constructing graphs of media-handling components. An OOB-Write has been detected in the function gst_parse_vorbis_setup_packet within vorbis_parse.c. The integer size is read from the input file without proper validation. As a result, size can exceed the fixed size of the pad->vorbis_mode_sizes array (which size is 256). When this happens, the for loop overwrites the entire pad structure with 0s and 1s, affecting adjacent memory as well. This OOB-write can overwrite up to 380 bytes of memory beyond the boundaries of the pad->vorbis_mode_sizes array. This vulnerability is fixed in 1.24.10.
CVSS 8.6 · Alta · EPSS 1,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
gstreamer
- Versiones
- < 1.24.10: Afectada
Sin corrección publicada
gst-plugins-base1.0 Debian:12
- Versiones
- 1.22.0-3
- 1.22.0-3+deb12u1
- 1.22.0-3+deb12u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.22.0-3+deb12u3
Actualiza a 1.22.0-3+deb12u3
gst-plugins-base1.0 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.24.10-1
Actualiza a 1.24.10-1
gst-plugins-base1.0 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.24.10-1
Actualiza a 1.24.10-1
gst-plugins-base1.0 Ubuntu:Pro:16.04:LTS
- Versiones
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.3-1ubuntu0.1
- 1.8.3-1ubuntu0.2
- 1.8.3-1ubuntu0.3
- 1.8.3-1ubuntu0.3+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.8.3-1ubuntu0.3+esm2
Actualiza a 1.8.3-1ubuntu0.3+esm2
gst-plugins-base0.10 Ubuntu:16.04:LTS
- Versiones
- 0.10.36-2
- 0.10.36-2ubuntu0.1
- 0.10.36-2ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
gst-plugins-base1.0 Ubuntu:Pro:18.04:LTS
- Versiones
- 1.12.3-1
- 1.12.4-1
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.0-2ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.1-1ubuntu1~ubuntu18.04.2
- 1.14.4-1ubuntu1.1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- 1.14.5-0ubuntu1~18.04.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.3+esm1
Actualiza a 1.14.5-0ubuntu1~18.04.3+esm1
gst-plugins-base1.0 Ubuntu:20.04:LTS
- Versiones
- 1.16.1-1
- 1.16.2-1
- 1.16.2-2
- 1.16.2-2ubuntu3
- 1.16.2-2ubuntu4
- 1.16.2-4
- 1.16.2-4ubuntu0.1
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- 1.16.3-0ubuntu1.2
- 1.16.3-0ubuntu1.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.16.3-0ubuntu1.4
Actualiza a 1.16.3-0ubuntu1.4
gst-plugins-base1.0 Ubuntu:22.04:LTS
- Versiones
- 1.18.5-1
- 1.19.90-1
- 1.20.0-1
- 1.20.0-2
- 1.20.1-1
- 1.20.1-1ubuntu0.1
- 1.20.1-1ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.20.1-1ubuntu0.4
Actualiza a 1.20.1-1ubuntu0.4
gst-plugins-base1.0 Ubuntu:24.04:LTS
- Versiones
- 1.22.6-1
- 1.22.7-1
- 1.22.8-1
- 1.22.10-1
- 1.24.1-1
- 1.24.1-1build1
- 1.24.2-1
- 1.24.2-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.24.2-1ubuntu0.2
Actualiza a 1.24.2-1ubuntu0.2
Fuentes originales
- https://securitylab.github.com/advisories/GHSL-2024-115_GHSL-2024-118_Gstreamer/
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8038.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0026.html
- https://lists.debian.org/debian-lts-announce/2024/12/msg00021.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47615