CVE-2024-47835
CVE-2024-47835 · GHSL-2024-263: Gstreamer NULL-pointer dereference in LRC subtitle parser
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
GStreamer is a library for constructing graphs of media-handling components. A null pointer dereference vulnerability has been detected in the parse_lrc function within gstsubparse.c. The parse_lrc function calls strchr() to find the character ']' in the string line. The pointer returned by this call is then passed to g_strdup(). However, if the string line does not contain the character ']', strchr() returns NULL, and a call to g_strdup(start + 1) leads to a null pointer dereference. This vulnerability is fixed in 1.24.10.
CVSS 6.8 · Media · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
gstreamer
- Versiones
- < 1.24.10: Afectada
Sin corrección publicada
gst-plugins-base1.0 Debian:12
- Versiones
- 1.22.0-3
- 1.22.0-3+deb12u1
- 1.22.0-3+deb12u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.22.0-3+deb12u3
Actualiza a 1.22.0-3+deb12u3
gst-plugins-base1.0 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.24.10-1
Actualiza a 1.24.10-1
gst-plugins-base1.0 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.24.10-1
Actualiza a 1.24.10-1
gst-plugins-base1.0 Ubuntu:Pro:16.04:LTS
- Versiones
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.3-1ubuntu0.1
- 1.8.3-1ubuntu0.2
- 1.8.3-1ubuntu0.3
- 1.8.3-1ubuntu0.3+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.8.3-1ubuntu0.3+esm2
Actualiza a 1.8.3-1ubuntu0.3+esm2
gst-plugins-base0.10 Ubuntu:16.04:LTS
- Versiones
- 0.10.36-2
- 0.10.36-2ubuntu0.1
- 0.10.36-2ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
gst-plugins-base1.0 Ubuntu:Pro:18.04:LTS
- Versiones
- 1.12.3-1
- 1.12.4-1
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.0-2ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.1-1ubuntu1~ubuntu18.04.2
- 1.14.4-1ubuntu1.1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- 1.14.5-0ubuntu1~18.04.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.5-0ubuntu1~18.04.3+esm1
Actualiza a 1.14.5-0ubuntu1~18.04.3+esm1
gst-plugins-base1.0 Ubuntu:20.04:LTS
- Versiones
- 1.16.1-1
- 1.16.2-1
- 1.16.2-2
- 1.16.2-2ubuntu3
- 1.16.2-2ubuntu4
- 1.16.2-4
- 1.16.2-4ubuntu0.1
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- 1.16.3-0ubuntu1.2
- 1.16.3-0ubuntu1.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.16.3-0ubuntu1.4
Actualiza a 1.16.3-0ubuntu1.4
gst-plugins-base1.0 Ubuntu:22.04:LTS
- Versiones
- 1.18.5-1
- 1.19.90-1
- 1.20.0-1
- 1.20.0-2
- 1.20.1-1
- 1.20.1-1ubuntu0.1
- 1.20.1-1ubuntu0.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.20.1-1ubuntu0.4
Actualiza a 1.20.1-1ubuntu0.4
gst-plugins-base1.0 Ubuntu:24.04:LTS
- Versiones
- 1.22.6-1
- 1.22.7-1
- 1.22.8-1
- 1.22.10-1
- 1.24.1-1
- 1.24.1-1build1
- 1.24.2-1
- 1.24.2-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.24.2-1ubuntu0.2
Actualiza a 1.24.2-1ubuntu0.2
Fuentes originales
- https://securitylab.github.com/advisories/GHSL-2024-263_Gstreamer/
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8039.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0029.html
- https://lists.debian.org/debian-lts-announce/2024/12/msg00021.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47835