CVE-2024-47888
CVE-2024-47888 · Action Text has possible ReDoS vulnerability in plain_text_for_blockquote_node
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Action Text brings rich text content and editing to Rails. Starting in version 6.0.0 and prior to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, and 7.2.1.1, there is a possible ReDoS vulnerability in the `plain_text_for_blockquote_node helper` in Action Text. Carefully crafted text can cause the `plain_text_for_blockquote_node` helper to take an unexpected amount of time, possibly resulting in a DoS vulnerability. All users running an affected release should either upgrade to versions 6.1.7.9, 7.0.8.5, 7.1.4.1, or 7.2.1.1 or apply the relevant patch immediately. As a workaround, users can avoid calling `plain_text_for_blockquote_node` or upgrade to Ruby 3.2. Ruby 3.2 has mitigations for this problem, so Rails applications using Ruby 3.2 or newer are unaffected. Rails 8.0.0.beta1 depends on Ruby 3.2 or greater so is unaffected.
CVSS 6.6 · Media · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
rails
- Versiones
- >= 6.0.0, < 6.1.7.9: Afectada
- >= 7.0.0, < 7.0.8.5: Afectada
- >= 7.1.0, < 7.1.4.1: Afectada
- >= 7.2.0, < 7.2.1.1: Afectada
Sin corrección publicada
rails Debian:12
- Versiones
- 2:6.1.7.3+dfsg-1
- 2:6.1.7.3+dfsg-10
- 2:6.1.7.3+dfsg-11
- 2:6.1.7.3+dfsg-12
- 2:6.1.7.3+dfsg-13
- 2:6.1.7.3+dfsg-2
- 2:6.1.7.3+dfsg-2~deb12u1
- 2:6.1.7.3+dfsg-3
- 2:6.1.7.3+dfsg-4
- 2:6.1.7.3+dfsg-5
- 2:6.1.7.3+dfsg-6
- 2:6.1.7.3+dfsg-7
- 2:6.1.7.3+dfsg-7~exp1
- 2:6.1.7.3+dfsg-8
- 2:6.1.7.3+dfsg-9
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.1.7.10+dfsg-1~deb12u1
Actualiza a 2:6.1.7.10+dfsg-1~deb12u1
rails Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:7.2.2.1+dfsg-1
Actualiza a 2:7.2.2.1+dfsg-1
rails Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:7.2.2.1+dfsg-1
Actualiza a 2:7.2.2.1+dfsg-1
rails Ubuntu:Pro:16.04:LTS
- Versiones
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:4.2.6-1ubuntu0.1~esm1
Actualiza a 2:4.2.6-1ubuntu0.1~esm1
rails Ubuntu:Pro:18.04:LTS
- Versiones
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:4.2.10-0ubuntu4+esm1
Actualiza a 2:4.2.10-0ubuntu4+esm1
rails Ubuntu:Pro:20.04:LTS
- Versiones
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:5.2.3+dfsg-3ubuntu0.1~esm1
Actualiza a 2:5.2.3+dfsg-3ubuntu0.1~esm1
rails Ubuntu:Pro:22.04:LTS
- Versiones
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.1.4.1+dfsg-8ubuntu2+esm1
Actualiza a 2:6.1.4.1+dfsg-8ubuntu2+esm1
rails Ubuntu:24.04:LTS
- Versiones
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:25.10
- Versiones
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.10
- Versiones
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.04:LTS
- Versiones
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/rails/rails/security/advisories/GHSA-wwhv-wxv9-rpgw
- https://github.com/rails/rails/commit/4f4312b21a6448336de7c7ab0c4d94b378def468
- https://github.com/rails/rails/commit/727b0946c3cab04b825c039435eac963d4e91822
- https://github.com/rails/rails/commit/ba286c0a310b7f19cf5cac2a7a4c9def5cf9882e
- https://github.com/rails/rails/commit/de0df7caebd9cb238a6f10dca462dc5f8d5e98b5
- https://nvd.nist.gov/vuln/detail/CVE-2024-47888