p PatchFirst

CVE-2024-51493

CVE-2024-51493 · API key access in settings without reauthentication in OctoPrint

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

OctoPrint provides a web interface for controlling consumer 3D printers. OctoPrint versions up until and including 1.10.2 contain a vulnerability that allows an attacker that has gained temporary control over an authenticated victim's OctoPrint browser session to retrieve/recreate/delete the user's or - if the victim has admin permissions - the global API key without having to reauthenticate by re-entering the user account's password. An attacker could use a stolen API key to access OctoPrint through its API, or disrupt workflows depending on the API key they deleted. This vulnerability will be patched in version 1.10.3 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 5.3 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • octoprint

    Versiones
    • < 1.10.3: Afectada

    Sin corrección publicada

  • octoprint PyPI

    Versiones
    • 1.10.0
    • 1.10.0rc1
    • 1.10.0rc2
    • 1.10.0rc3
    • 1.10.0rc4
    • 1.10.1
    • 1.10.2
    • 1.3.11
    • 1.3.12
    • 1.3.12rc1
    • 1.3.12rc3
    • 1.4.0
    • 1.4.0rc1
    • 1.4.0rc2
    • 1.4.0rc3
    • 1.4.0rc4
    • 1.4.0rc5
    • 1.4.0rc6
    • 1.4.1
    • 1.4.1rc1
    • 1.4.1rc2
    • 1.4.1rc3
    • 1.4.1rc4
    • 1.4.2
    • 1.5.0
    • 1.5.0rc1
    • 1.5.0rc2
    • 1.5.0rc3
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.6.0
    • 1.6.0rc1
    • 1.6.0rc2
    • 1.6.0rc3
    • 1.6.1
    • 1.7.0
    • 1.7.0rc1
    • 1.7.0rc2
    • 1.7.0rc3
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8.0
    • 1.8.0rc1
    • 1.8.0rc2
    • 1.8.0rc3
    • 1.8.0rc4
    • 1.8.0rc5
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.8.4
    • 1.8.5
    • 1.8.6
    • 1.8.7
    • 1.9.0
    • 1.9.0rc1
    • 1.9.0rc2
    • 1.9.0rc3
    • 1.9.0rc4
    • 1.9.0rc5
    • 1.9.0rc6
    • 1.9.1
    • 1.9.2
    • 1.9.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.10.3

    Actualiza a 1.10.3

Fuentes originales

Comprueba tu servidor →