CVE-2024-52596
CVE-2024-52596 · SimpleSAMLphp xml-common XXE vulnerability
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
SimpleSAMLphp xml-common is a common classes for handling XML-structures. When loading an (untrusted) XML document, for example the SAMLResponse, it's possible to induce an XXE. This vulnerability is fixed in 1.19.0.
CVSS 8.8 · Alta · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
xml-common
- Versiones
- < 1.20.0: Afectada
Sin corrección publicada
simplesamlphp Debian:12
- Versiones
- 1.19.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.19.7-1+deb12u1
Actualiza a 1.19.7-1+deb12u1
simplesamlphp Debian:14
- Versiones
- 1.10.0-1
- 1.11.0-1
- 1.12.0-1
- 1.12.0~rc1-1
- 1.12.0~rc2-1
- 1.13.0-1
- 1.13.1-1
- 1.13.1-2
- 1.13.2-1
- 1.14.0-1
- 1.14.1-1
- 1.14.10-1
- 1.14.11-1
- 1.14.15-1
- 1.14.2-1
- 1.14.2-2
- 1.14.3-1
- 1.14.4-1
- 1.14.5-1
- 1.14.6-1
- 1.14.7-1
- 1.14.8-1
- 1.14.9-1
- 1.15.0-1
- 1.15.1-1
- 1.15.2-1
- 1.15.3-1
- 1.15.4-1
- 1.16.0-1
- 1.16.1-1
- 1.16.2-1
- 1.16.3-1
- 1.17.0-1
- 1.17.1-1
- 1.17.2-1
- 1.17.2-2
- 1.17.3-1
- 1.17.4-1
- 1.17.5-1
- 1.17.6-1
- 1.17.6-2
- 1.18.1-1
- 1.18.4-1
- 1.18.5-1
- 1.18.6-1
- 1.18.7-1
- 1.18.8-1
- 1.19.0-1
- 1.19.1-1
- 1.19.1-1.1
- 1.19.6-1
- 1.19.7-1
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.6.3-1
- 1.6.3-2
- 1.6.3-3
- 1.7.0-1
- 1.7.0-2
- 1.8.0-1
- 1.8.1-1
- 1.8.2-1
- 1.9.0-1
- 1.9.0~rc1-1
- 1.9.0~rc2-1
- 1.9.1-1
- 1.9.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.19.7-1+deb12u1
Actualiza a 1.19.7-1+deb12u1
simplesamlphp/xml-common Packagist
- Versiones
- 0.8.11
- 0.8.12
- v0.1.0
- v0.1.1
- v0.1.2
- v0.10.0
- v0.10.1
- v0.10.2
- v0.10.3
- v0.11.0
- v0.11.1
- v0.11.2
- v0.11.3
- v0.12.0
- v0.12.1
- v0.12.2
- v0.12.3
- v0.12.4
- v0.2.0
- v0.2.1
- v0.3.0
- v0.3.1
- v0.3.2
- v0.4.0
- v0.4.1
- v0.4.2
- v0.4.3
- v0.4.4
- v0.4.5
- v0.4.6
- v0.4.7
- v0.4.8
- v0.4.9
- v0.5.0
- v0.5.1
- v0.5.2
- v0.5.3
- v0.5.4
- v0.5.5
- v0.5.6
- v0.5.7
- v0.5.8
- v0.6.0
- v0.6.1
- v0.6.2
- v0.7.0
- v0.7.1
- v0.8.0
- v0.8.1
- v0.8.10
- v0.8.13
- v0.8.14
- v0.8.15
- v0.8.2
- v0.8.3
- v0.8.4
- v0.8.5
- v0.8.6
- v0.8.7
- v0.8.8
- v0.8.9
- v0.9.0
- v0.9.1
- v0.9.2
- v1.0.0
- v1.0.1
- v1.0.2
- v1.1.0
- v1.1.1
- v1.1.2
- v1.10.0
- v1.11.0
- v1.11.1
- v1.11.2
- v1.11.3
- v1.11.4
- v1.11.5
- v1.11.6
- v1.11.7
- v1.11.8
- v1.12.0
- v1.12.1
- v1.12.2
- v1.12.3
- v1.13.0
- v1.14.0
- v1.14.1
- v1.14.2
- v1.15.0
- v1.16.0
- v1.16.1
- v1.16.2
- v1.17.0
- v1.17.1
- v1.17.2
- v1.17.3
- v1.18.0
- v1.18.1
- v1.18.2
- v1.18.3
- v1.18.4
- v1.18.5
- v1.19.0
- v1.2.0
- v1.3.0
- v1.3.1
- v1.4.0
- v1.6.0
- v1.6.1
- v1.6.2
- v1.6.3
- v1.7.0
- v1.7.1
- v1.7.2
- v1.7.3
- v1.7.4
- v1.8.0
- v1.9.0
- v1.9.1
- v1.9.2
- v1.9.3
- v1.9.4
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.20.0
Actualiza a 1.20.0
simplesamlphp Ubuntu:Pro:16.04:LTS
- Versiones
- 1.13.2-1
- 1.14.0-1
- 1.14.0-1ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.14.0-1ubuntu2+esm1
Actualiza a 1.14.0-1ubuntu2+esm1
simplesamlphp Ubuntu:Pro:18.04:LTS
- Versiones
- 1.14.15-1
- 1.15.0-1
- 1.15.1-1
- 1.15.2-1
- 1.15.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.15.3-1ubuntu0.1~esm1
Actualiza a 1.15.3-1ubuntu0.1~esm1
simplesamlphp Ubuntu:Pro:20.04:LTS
- Versiones
- 1.17.5-1
- 1.17.6-1
- 1.17.6-2
- 1.18.1-1
- 1.18.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.18.4-1ubuntu0.1~esm1
Actualiza a 1.18.4-1ubuntu0.1~esm1
simplesamlphp Ubuntu:Pro:22.04:LTS
- Versiones
- 1.19.1-1
- 1.19.1-1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.19.1-1.1ubuntu0.1~esm1
Actualiza a 1.19.1-1.1ubuntu0.1~esm1
simplesamlphp Ubuntu:24.04:LTS
- Versiones
- 1.19.7-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.19.7-1+deb12u1ubuntu0.1
Actualiza a 1.19.7-1+deb12u1ubuntu0.1
simplesamlphp Ubuntu:25.10
- Versiones
- 1.19.7-1+deb12u1
- 1.19.7-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada