CVE-2024-54677
CVE-2024-54677 · Apache Tomcat: DoS in examples web application
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Uncontrolled Resource Consumption vulnerability in the examples web application provided with Apache Tomcat leads to denial of service. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.1, from 10.1.0-M1 through 10.1.33, from 9.0.0.M1 through 9.9.97. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.2, 10.1.34 or 9.0.98, which fixes the issue.
CVSS 5.3 · Media · EPSS 1,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
apache tomcat
- Versiones
- ≥ 11.0.0-M1, ≤ 11.0.1: Afectada (semver)
- ≥ 10.1.0-M1, ≤ 10.1.33: Afectada (semver)
- ≥ 9.0.0.M1, ≤ 9.0.97: Afectada (semver)
- ≥ 8.5.0, ≤ 8.5.100: Afectada (semver)
- ≥ 3, < 8.5.0: Desconocido (semver)
- ≥ 10.0.0-M1, ≤ 10.0.27: Desconocido (semver)
Sin corrección publicada
tomcat10 Debian:12
- Versiones
- 10.1.10-1
- 10.1.13-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.20-1
- 10.1.23-1
- 10.1.25-1
- 10.1.25-1~bpo12+1
- 10.1.25-2
- 10.1.30-1
- 10.1.30-1~bpo12+1
- 10.1.31-1
- 10.1.33-1
- 10.1.33-1~bpo12+1
- 10.1.6-1
- 10.1.6-1+deb12u1
- 10.1.6-1+deb12u2
- 10.1.7-1
- 10.1.8-1
- 10.1.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.34-0+deb12u1
Actualiza a 10.1.34-0+deb12u1
tomcat10 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.34-1
Actualiza a 10.1.34-1
tomcat10 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.34-1
Actualiza a 10.1.34-1
tomcat9 Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat9 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.70-2
Actualiza a 9.0.70-2
tomcat8 Ubuntu:Pro:16.04:LTS
- Versiones
- 8.0.26-1
- 8.0.28-1
- 8.0.30-1
- 8.0.32-1
- 8.0.32-1ubuntu1
- 8.0.32-1ubuntu1.1
- 8.0.32-1ubuntu1.2
- 8.0.32-1ubuntu1.3
- 8.0.32-1ubuntu1.4
- 8.0.32-1ubuntu1.5
- 8.0.32-1ubuntu1.6
- 8.0.32-1ubuntu1.7
- 8.0.32-1ubuntu1.8
- 8.0.32-1ubuntu1.9
- 8.0.32-1ubuntu1.10
- 8.0.32-1ubuntu1.11
- 8.0.32-1ubuntu1.13
- 8.0.32-1ubuntu1.13+esm1
- 8.0.32-1ubuntu1.13+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat8 Ubuntu:Pro:18.04:LTS
- Versiones
- 8.5.21-1ubuntu1
- 8.5.29-1
- 8.5.30-1
- 8.5.30-1ubuntu1
- 8.5.30-1ubuntu1.2
- 8.5.30-1ubuntu1.3
- 8.5.30-1ubuntu1.4
- 8.5.39-1ubuntu1~18.04.1
- 8.5.39-1ubuntu1~18.04.2
- 8.5.39-1ubuntu1~18.04.3
- 8.5.39-1ubuntu1~18.04.3+esm1
- 8.5.39-1ubuntu1~18.04.3+esm2
- 8.5.39-1ubuntu1~18.04.3+esm3
- 8.5.39-1ubuntu1~18.04.3+esm4
- 8.5.39-1ubuntu1~18.04.3+esm5
- 8.5.39-1ubuntu1~18.04.3+esm6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:Pro:18.04:LTS
- Versiones
- 9.0.16-3~18.04.1
- 9.0.16-3ubuntu0.18.04.1
- 9.0.16-3ubuntu0.18.04.2
- 9.0.16-3ubuntu0.18.04.2+esm1
- 9.0.16-3ubuntu0.18.04.2+esm2
- 9.0.16-3ubuntu0.18.04.2+esm3
- 9.0.16-3ubuntu0.18.04.2+esm4
- 9.0.16-3ubuntu0.18.04.2+esm5
- 9.0.16-3ubuntu0.18.04.2+esm6
- 9.0.16-3ubuntu0.18.04.2+esm7
- 9.0.16-3ubuntu0.18.04.2+esm8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:Pro:20.04:LTS
- Versiones
- 9.0.24-1
- 9.0.27-1
- 9.0.31-1
- 9.0.31-1ubuntu0.1
- 9.0.31-1ubuntu0.2
- 9.0.31-1ubuntu0.3
- 9.0.31-1ubuntu0.4
- 9.0.31-1ubuntu0.5
- 9.0.31-1ubuntu0.6
- 9.0.31-1ubuntu0.7
- 9.0.31-1ubuntu0.8
- 9.0.31-1ubuntu0.9
- 9.0.31-1ubuntu0.9+esm1
- 9.0.31-1ubuntu0.9+esm2
- 9.0.31-1ubuntu0.9+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat9 Ubuntu:Pro:22.04:LTS
- Versiones
- 9.0.43-3
- 9.0.54-1
- 9.0.55-1
- 9.0.58-1
- 9.0.58-1ubuntu0.1
- 9.0.58-1ubuntu0.1+esm1
- 9.0.58-1ubuntu0.1+esm2
- 9.0.58-1ubuntu0.1+esm3
- 9.0.58-1ubuntu0.1+esm4
- 9.0.58-1ubuntu0.2
- 9.0.58-1ubuntu0.2+esm1
- 9.0.58-1ubuntu0.2+esm2
- 9.0.58-1ubuntu0.2+esm3
- 9.0.58-1ubuntu0.2+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
tomcat10 Ubuntu:Pro:24.04:LTS
- Versiones
- 10.1.10-1
- 10.1.14-1
- 10.1.15-1
- 10.1.16-1
- 10.1.16-1ubuntu0.1~esm1
- 10.1.16-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm3
Actualiza a 10.1.16-1ubuntu0.1~esm3
Fuentes originales
- https://lists.apache.org/thread/tdtbbxpg5trdwc2wnopcth9ccvdftq2n
- http://www.openwall.com/lists/oss-security/2024/12/17/5
- http://www.openwall.com/lists/oss-security/2024/12/17/6
- http://www.openwall.com/lists/oss-security/2024/12/18/1
- https://security.netapp.com/advisory/ntap-20250131-0006/
- https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-54677