p PatchFirst

CVE-2024-7272

CVE-2024-7272 · FFmpeg swresample.c fill_audiodata heap-based overflow

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A vulnerability, which was classified as critical, was found in FFmpeg up to 5.1.5. This affects the function fill_audiodata of the file /libswresample/swresample.c. The manipulation leads to heap-based buffer overflow. It is possible to initiate the attack remotely. This issue was fixed in version 6.0 by 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 but a backport for 5.1 was forgotten. The exploit has been disclosed to the public and may be used. Upgrading to version 5.1.6 and 6.0 9903ba28c28ab18dc7b7b6fb8571cc8b5caae1a6 is able to address this issue. It is recommended to upgrade the affected component.

CVSS 6.9 · Media · EPSS 1,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • ffmpeg

    Versiones
    • 5.1.0: Afectada
    • 5.1.1: Afectada
    • 5.1.2: Afectada
    • 5.1.3: Afectada
    • 5.1.4: Afectada
    • 5.1.5: Afectada

    Sin corrección publicada

  • ffmpeg Debian:12

    Versiones
    • 7:5.1.3-1
    • 7:5.1.3-2
    • 7:5.1.4-0+deb12u1
    • 7:5.1.5-0+deb12u1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7:5.1.6-0+deb12u1

    Actualiza a 7:5.1.6-0+deb12u1

  • ffmpeg Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7:6.0-4

    Actualiza a 7:6.0-4

  • ffmpeg Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 7:6.0-4

    Actualiza a 7:6.0-4

Fuentes originales

Comprueba tu servidor →