CVE-2025-2177
CVE-2025-2177 · libzvbi search.c vbi_search_new integer overflow
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A vulnerability classified as critical was found in libzvbi up to 0.2.43. This vulnerability affects the function vbi_search_new of the file src/search.c. The manipulation of the argument pat_len leads to integer overflow. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The patch is identified as ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.
CVSS 6.9 · Media · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
libzvbi
- Versiones
- 0.2.0: Afectada
- 0.2.1: Afectada
- 0.2.2: Afectada
- 0.2.3: Afectada
- 0.2.4: Afectada
- 0.2.5: Afectada
- 0.2.6: Afectada
- 0.2.7: Afectada
- 0.2.8: Afectada
- 0.2.9: Afectada
- 0.2.10: Afectada
- 0.2.11: Afectada
- 0.2.12: Afectada
- 0.2.13: Afectada
- 0.2.14: Afectada
- 0.2.15: Afectada
- 0.2.16: Afectada
- 0.2.17: Afectada
- 0.2.18: Afectada
- 0.2.19: Afectada
- 0.2.20: Afectada
- 0.2.21: Afectada
- 0.2.22: Afectada
- 0.2.23: Afectada
- 0.2.24: Afectada
- 0.2.25: Afectada
- 0.2.26: Afectada
- 0.2.27: Afectada
- 0.2.28: Afectada
- 0.2.29: Afectada
- 0.2.30: Afectada
- 0.2.31: Afectada
- 0.2.32: Afectada
- 0.2.33: Afectada
- 0.2.34: Afectada
- 0.2.35: Afectada
- 0.2.36: Afectada
- 0.2.37: Afectada
- 0.2.38: Afectada
- 0.2.39: Afectada
- 0.2.40: Afectada
- 0.2.41: Afectada
- 0.2.42: Afectada
- 0.2.43: Afectada
Sin corrección publicada
zvbi Debian:12
- Versiones
- 0.2.41-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.41-1+deb12u1
Actualiza a 0.2.41-1+deb12u1
zvbi Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.44-1
Actualiza a 0.2.44-1
zvbi Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.44-1
Actualiza a 0.2.44-1
zvbi Ubuntu:14.04:LTS
- Versiones
- 0.2.33-7
- 0.2.35-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
zvbi Ubuntu:Pro:16.04:LTS
- Versiones
- 0.2.35-9
- 0.2.35-10
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.35-10ubuntu0.1~esm1
Actualiza a 0.2.35-10ubuntu0.1~esm1
zvbi Ubuntu:Pro:18.04:LTS
- Versiones
- 0.2.35-13
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.35-13ubuntu0.1~esm1
Actualiza a 0.2.35-13ubuntu0.1~esm1
zvbi Ubuntu:Pro:20.04:LTS
- Versiones
- 0.2.35-16
- 0.2.35-17
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.35-17ubuntu0.1~esm1
Actualiza a 0.2.35-17ubuntu0.1~esm1
zvbi Ubuntu:Pro:22.04:LTS
- Versiones
- 0.2.35-18
- 0.2.35-19
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.35-19ubuntu0.1~esm1
Actualiza a 0.2.35-19ubuntu0.1~esm1
zvbi Ubuntu:Pro:24.04:LTS
- Versiones
- 0.2.41-2
- 0.2.42-1
- 0.2.42-1.1
- 0.2.42-1.2
- 0.2.42-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.2.42-2ubuntu0.24.04.1~esm1
Actualiza a 0.2.42-2ubuntu0.24.04.1~esm1
Fuentes originales
- https://vuldb.com/?id.299206
- https://vuldb.com/?ctiid.299206
- https://vuldb.com/?submit.512803
- https://github.com/zapping-vbi/zvbi/security/advisories/GHSA-g7cg-7gw9-v8cf
- https://github.com/zapping-vbi/zvbi/commit/ca1672134b3e2962cd392212c73f44f8f4cb489f
- https://github.com/zapping-vbi/zvbi/releases/tag/v0.2.44
- https://nvd.nist.gov/vuln/detail/CVE-2025-2177