CVE-2025-24374
CVE-2025-24374 · Twig fixes a security issue where escaping was missing when using null coalesce operator (??)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Twig is a template language for PHP. When using the ?? operator, output escaping was missing for the expression on the left side of the operator. This vulnerability is fixed in 3.19.0.
CVSS 4.3 · Media · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
twig
- Versiones
- >= 3.16.0, < 3.19.0: Afectada
Sin corrección publicada
php-twig Debian:12
- Versiones
- 3.10.1-1
- 3.10.3-1
- 3.11.0-1
- 3.13.0-1
- 3.14.0-1
- 3.14.0-2
- 3.14.0-3
- 3.14.0-4
- 3.14.2-1
- 3.14.2-2
- 3.14.2-3
- 3.15.0-1
- 3.15.0-2
- 3.17.1-1
- 3.17.1-2
- 3.18.0-1
- 3.18.0-2
- 3.18.0-4
- 3.18.0-5
- 3.18.0-6
- 3.18.0-7
- 3.19.0-1
- 3.19.0-1~bootstrap
- 3.20.0-1
- 3.20.0-1~bootstrap
- 3.20.0-2
- 3.21.1-1
- 3.21.1-2
- 3.21.1-3
- 3.22.0-1
- 3.22.0-2
- 3.22.1-1
- 3.22.1-2
- 3.22.1-3
- 3.22.2-1
- 3.22.2-2
- 3.23.0-1
- 3.23.0-2
- 3.24.0-1
- 3.26.0-1
- 3.27.0-1
- 3.27.1-1
- 3.28.0-1
- 3.5.1-1
- 3.5.1-1+deb12u1
- 3.5.1-1+deb12u2
- 3.5.1-1+deb12u3
- 3.6.0-1
- 3.6.1-1
- 3.7.0-1
- 3.7.1-1
- 3.7.1-2
- 3.7.1-3
- 3.8.0-1
- 3.8.0-2
- 3.8.0-3
- 3.8.0-4
- 3.9.3-1
- 4.0.0~alpha1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-twig Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.19.0-1~bootstrap
Actualiza a 3.19.0-1~bootstrap
php-twig Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.19.0-1~bootstrap
Actualiza a 3.19.0-1~bootstrap
twig/twig Packagist
- Versiones
- v3.16.0
- v3.17.0
- v3.17.1
- v3.18.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.16.0, < 3.19.0
Actualiza a 3.19.0
twig Ubuntu:Pro:16.04:LTS
- Versiones
- 1.20.0-1
- 1.23.1-1ubuntu1
- 1.23.1-1ubuntu4
- 1.23.1-1ubuntu4+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
twig Ubuntu:Pro:18.04:LTS
- Versiones
- 1.24.0-2ubuntu1
- 2.4.4-2ubuntu1
- 2.4.6-1
- 2.4.6-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada