p PatchFirst

CVE-2025-24813

CVE-2025-24813 · Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If all of the following were true, a malicious user was able to perform remote code execution: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - application was using Tomcat's file based session persistence with the default storage location - application included a library that may be leveraged in a deserialization attack Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

CVSS 10.0 · Crítica · EPSS 99,9% · En el catálogo KEV · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • apache tomcat

    Versiones
    • ≥ 11.0.0-M1, ≤ 11.0.2: Afectada (semver)
    • ≥ 10.1.0-M1, ≤ 10.1.34: Afectada (semver)
    • ≥ 9.0.0.M1, ≤ 9.0.98: Afectada (semver)
    • ≥ 8.5.0, ≤ 8.5.100: Afectada (semver)
    • ≥ 3, < 8.5.0: Desconocido (semver)
    • ≥ 10.0.0-M1, ≤ 10.0.27: Desconocido (semver)

    Sin corrección publicada

  • tomcat10 Debian:12

    Versiones
    • 10.1.10-1
    • 10.1.13-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.20-1
    • 10.1.23-1
    • 10.1.25-1
    • 10.1.25-1~bpo12+1
    • 10.1.25-2
    • 10.1.30-1
    • 10.1.30-1~bpo12+1
    • 10.1.31-1
    • 10.1.33-1
    • 10.1.33-1~bpo12+1
    • 10.1.34-0+deb12u1
    • 10.1.6-1
    • 10.1.6-1+deb12u1
    • 10.1.6-1+deb12u2
    • 10.1.7-1
    • 10.1.8-1
    • 10.1.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 10.1.34-0+deb12u2

    Actualiza a 10.1.34-0+deb12u2

  • tomcat10 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 10.1.35-1

    Actualiza a 10.1.35-1

  • tomcat10 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 10.1.35-1

    Actualiza a 10.1.35-1

  • tomcat9 Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2

    Actualiza a 9.0.70-2

  • tomcat9 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2

    Actualiza a 9.0.70-2

  • tomcat9 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2

    Actualiza a 9.0.70-2

  • tomcat9 Ubuntu:Pro:18.04:LTS

    Versiones
    • 9.0.16-3~18.04.1
    • 9.0.16-3ubuntu0.18.04.1
    • 9.0.16-3ubuntu0.18.04.2
    • 9.0.16-3ubuntu0.18.04.2+esm1
    • 9.0.16-3ubuntu0.18.04.2+esm2
    • 9.0.16-3ubuntu0.18.04.2+esm3
    • 9.0.16-3ubuntu0.18.04.2+esm4
    • 9.0.16-3ubuntu0.18.04.2+esm5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.16-3ubuntu0.18.04.2+esm6

    Actualiza a 9.0.16-3ubuntu0.18.04.2+esm6

  • tomcat9 Ubuntu:Pro:20.04:LTS

    Versiones
    • 9.0.24-1
    • 9.0.27-1
    • 9.0.31-1
    • 9.0.31-1ubuntu0.1
    • 9.0.31-1ubuntu0.2
    • 9.0.31-1ubuntu0.3
    • 9.0.31-1ubuntu0.4
    • 9.0.31-1ubuntu0.5
    • 9.0.31-1ubuntu0.6
    • 9.0.31-1ubuntu0.7
    • 9.0.31-1ubuntu0.8
    • 9.0.31-1ubuntu0.9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.31-1ubuntu0.9+esm1

    Actualiza a 9.0.31-1ubuntu0.9+esm1

  • tomcat9 Ubuntu:Pro:22.04:LTS

    Versiones
    • 9.0.43-3
    • 9.0.54-1
    • 9.0.55-1
    • 9.0.58-1
    • 9.0.58-1ubuntu0.1
    • 9.0.58-1ubuntu0.1+esm1
    • 9.0.58-1ubuntu0.1+esm2
    • 9.0.58-1ubuntu0.1+esm3
    • 9.0.58-1ubuntu0.1+esm4
    • 9.0.58-1ubuntu0.2
    • 9.0.58-1ubuntu0.2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.58-1ubuntu0.2+esm2

    Actualiza a 9.0.58-1ubuntu0.2+esm2

  • tomcat10 Ubuntu:Pro:24.04:LTS

    Versiones
    • 10.1.10-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 10.1.16-1ubuntu0.1~esm1

    Actualiza a 10.1.16-1ubuntu0.1~esm1

  • tomcat9 Ubuntu:Pro:24.04:LTS

    Versiones
    • 9.0.70-1ubuntu1
    • 9.0.70-2
    • 9.0.70-2ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2ubuntu0.1+esm1

    Actualiza a 9.0.70-2ubuntu0.1+esm1

  • tomcat9 Ubuntu:25.10

    Versiones
    • 9.0.70-2ubuntu1.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2ubuntu2

    Actualiza a 9.0.70-2ubuntu2

Fuentes originales

Comprueba tu servidor →