CVE-2025-27614
CVE-2025-27614 · Gitk allows arbitrary command execution
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Gitk is a Tcl/Tk based Git history browser. Starting with 2.41.0, a Git repository can be crafted in such a way that with some social engineering a user who has cloned the repository can be tricked into running any script (e.g., Bourne shell, Perl, Python, ...) supplied by the attacker by invoking gitk filename, where filename has a particular structure. The script is run with the privileges of the user. This vulnerability is fixed in 2.43.7, 2.44.4, 2.45.4, 2.46.4, 2.47.3, 2.48.2, 2.49.1, and 2.50.
CVSS 8.6 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
gitk
- Versiones
- >= 2.41.0, < 2.43.7: Afectada
- >= 2.44.0, < 2.44.4: Afectada
- >= 2.45.0, < 2.45.4: Afectada
- >= 2.46.0, < 2.46.4: Afectada
- >= 2.47.0, < 2.47.3: Afectada
- >= 2.48.0, < 2.48.2: Afectada
- >= 2.49.0, < 2.49.1: Afectada
- >= 2.50.0, < 2.50.1: Afectada
Sin corrección publicada
git Debian:13
- Versiones
- 1:2.47.2-0.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:2.47.3-0+deb13u1
Actualiza a 1:2.47.3-0+deb13u1
git Debian:14
- Versiones
- 1:2.47.2-0.2
- 1:2.48.0~rc1+next.20250101-1
- 1:2.49.0+next.20250314-1
- 1:2.49.0-1
- 1:2.49.0-2
- 1:2.49.0-3
- 1:2.50.0+next.20250615-1
- 1:2.50.0-1
- 1:2.50.0~rc0+next.20250528-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:2.50.1-0.1
Actualiza a 1:2.50.1-0.1
git Ubuntu:24.04:LTS
- Versiones
- 1:2.40.1-1ubuntu1
- 1:2.43.0-1ubuntu1
- 1:2.43.0-1ubuntu5
- 1:2.43.0-1ubuntu6
- 1:2.43.0-1ubuntu7
- 1:2.43.0-1ubuntu7.1
- 1:2.43.0-1ubuntu7.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:2.43.0-1ubuntu7.3
Actualiza a 1:2.43.0-1ubuntu7.3