p PatchFirst

CVE-2025-27789

CVE-2025-27789 · Inefficient RexExp complexity in generated code with .replace when transpiling named capturing groups

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Babel is a compiler for writing next generation JavaScript. When using versions of Babel prior to 7.26.10 and 8.0.0-alpha.17 to compile regular expression named capturing groups, Babel will generate a polyfill for the `.replace` method that has quadratic complexity on some specific replacement pattern strings (i.e. the second argument passed to `.replace`). Generated code is vulnerable if all the following conditions are true: Using Babel to compile regular expression named capturing groups, using the `.replace` method on a regular expression that contains named capturing groups, and the code using untrusted strings as the second argument of `.replace`. This problem has been fixed in `@babel/helpers` and `@babel/runtime` 7.26.10 and 8.0.0-alpha.17. It's likely that individual users do not directly depend on `@babel/helpers`, and instead depend on `@babel/core` (which itself depends on `@babel/helpers`). Upgrading to `@babel/core` 7.26.10 is not required, but it guarantees use of a new enough `@babel/helpers` version. Note that just updating Babel dependencies is not enough; one will also need to re-compile the code. No known workarounds are available.

CVSS 6.2 · Media · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • babel

    Versiones
    • < 7.26.10: Afectada
    • >= 8.0.0-alpha.0, < 8.0.0-alpha.17: Afectada

    Sin corrección publicada

  • @babel/helpers npm

    Intervalos de versiones afectados
    • SEMVER: < 7.26.10

    Actualiza a 7.26.10

  • @babel/runtime npm

    Intervalos de versiones afectados
    • SEMVER: < 7.26.10

    Actualiza a 7.26.10

  • @babel/runtime-corejs2 npm

    Intervalos de versiones afectados
    • SEMVER: < 7.26.10

    Actualiza a 7.26.10

  • @babel/runtime-corejs3 npm

    Intervalos de versiones afectados
    • SEMVER: < 7.26.10

    Actualiza a 7.26.10

  • @babel/helpers npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17

    Actualiza a 8.0.0-alpha.17

  • @babel/runtime npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17

    Actualiza a 8.0.0-alpha.17

  • @babel/runtime-corejs2 npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17

    Actualiza a 8.0.0-alpha.17

  • @babel/runtime-corejs3 npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 8.0.0-alpha.0, < 8.0.0-alpha.17

    Actualiza a 8.0.0-alpha.17

  • node-babel Ubuntu:18.04:LTS

    Versiones
    • 6.26.0+dfsg-3build5
    • 6.26.0+dfsg-3build6
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-babel Ubuntu:20.04:LTS

    Versiones
    • 6.26.0+dfsg-3build6
    • 6.26.0+repack-2
    • 6.26.0+repack-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-babel7 Ubuntu:22.04:LTS

    Versiones
    • 7.12.12+~cs150.141.84-6
    • 7.12.12+~cs150.141.84-7
    • 7.12.12+~cs150.141.84-8
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-babel7 Ubuntu:24.04:LTS

    Versiones
    • 7.20.15+ds1+~cs214.269.168-4
    • 7.20.15+ds1+~cs214.269.168-5
    • 7.20.15+ds1+~cs214.269.168-6
    • 7.20.15+ds1+~cs214.269.168-6build1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-babel7 Ubuntu:25.10

    Versiones
    • 7.20.15+ds1+~cs214.269.168-8
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-babel7 Ubuntu:26.10

    Versiones
    • 7.20.15+ds1+~cs214.269.168-16
    • 7.20.15+ds1+~cs214.269.168-17build1
    • 7.20.15+ds1+~cs214.269.168-17build2
    • 7.20.15+ds1+~cs214.269.168-18
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-babel7 Ubuntu:26.04:LTS

    Versiones
    • 7.20.15+ds1+~cs214.269.168-8
    • 7.20.15+ds1+~cs214.269.168-9
    • 7.20.15+ds1+~cs214.269.168-11build1
    • 7.20.15+ds1+~cs214.269.168-14
    • 7.20.15+ds1+~cs214.269.168-16
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →