CVE-2025-30358
CVE-2025-30358 · Mesop Class Pollution vulnerability leads to DoS and Jailbreak attacks
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Mesop is a Python-based UI framework that allows users to build web applications. A class pollution vulnerability in Mesop prior to version 0.14.1 allows attackers to overwrite global variables and class attributes in certain Mesop modules during runtime. This vulnerability could directly lead to a denial of service (DoS) attack against the server. Additionally, it could also result in other severe consequences given the application's implementation, such as identity confusion, where an attacker could impersonate an assistant or system role within conversations. This impersonation could potentially enable jailbreak attacks when interacting with large language models (LLMs). Just like the Javascript's prototype pollution, this vulnerability could leave a way for attackers to manipulate the intended data-flow or control-flow of the application at runtime and lead to severe consequences like remote code execution when gadgets are available. Users should upgrade to version 0.14.1 to obtain a fix for the issue.
CVSS 8.1 · Alta · EPSS 0,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
mesop
- Versiones
- < 0.14.1: Afectada
Sin corrección publicada
mesop PyPI
- Versiones
- 0.0.1
- 0.10.0
- 0.10.0rc0
- 0.10.0rc1
- 0.10.0rc2
- 0.11.0
- 0.11.0rc0
- 0.11.1
- 0.12.0
- 0.12.0rc0
- 0.12.1
- 0.12.10b1
- 0.12.10b2
- 0.12.10b3
- 0.12.10rc1
- 0.12.1rc0
- 0.12.2
- 0.12.3
- 0.12.3rc0
- 0.12.4
- 0.12.4rc0
- 0.12.5
- 0.12.5b1
- 0.12.5rc1
- 0.12.6
- 0.12.6rc1
- 0.12.7
- 0.12.7b1
- 0.12.7rc1
- 0.12.8
- 0.12.8b1
- 0.12.8rc1
- 0.12.9
- 0.12.9rc1
- 0.13.0
- 0.13.0rc1
- 0.14.0
- 0.14.1rc1
- 0.14rc1
- 0.3.1
- 0.3.2
- 0.3.3
- 0.3.4
- 0.4.0
- 0.4.1
- 0.4.2
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.4
- 0.5.5
- 0.5.6
- 0.6.0
- 0.7.0
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.0rc0
- 0.9.0
- 0.9.0rc1
- 0.9.1
- 0.9.1rc1
- 0.9.2
- 0.9.2rc1
- 0.9.3
- 0.9.3rc0
- 0.9.4
- 0.9.4rc0
- 0.9.5
- 0.9.5rc0
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.14.1
Actualiza a 0.14.1