CVE-2025-32434
CVE-2025-32434 · PyTorch: `torch.load` with `weights_only=True` leads to remote code execution
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
PyTorch is a Python package that provides tensor computation with strong GPU acceleration and deep neural networks built on a tape-based autograd system. In version 2.5.1 and prior, a Remote Command Execution (RCE) vulnerability exists in PyTorch when loading a model using torch.load with weights_only=True. This issue has been patched in version 2.6.0.
CVSS 9.3 · Crítica · EPSS 2,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
pytorch
- Versiones
- < 2.6.0: Afectada
Sin corrección publicada
pytorch Debian:12
- Versiones
- 1.13.1+dfsg-4
- 1.13.1+dfsg-5
- 2.0.1+dfsg-1
- 2.0.1+dfsg-1~exp1
- 2.0.1+dfsg-2
- 2.0.1+dfsg-4
- 2.0.1+dfsg-5
- 2.1.2+dfsg-1
- 2.1.2+dfsg-2
- 2.1.2+dfsg-4
- 2.12.0+dfsg2-1
- 2.12.0+dfsg2-1~exp1
- 2.12.0+dfsg2-1~exp2
- 2.12.0+dfsg2-2
- 2.12.0+dfsg2-3
- 2.12.0+dfsg2-4
- 2.12.1+dfsg-1
- 2.4.1-1
- 2.4.1-3
- 2.4.1-4
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-3
- 2.5.1+dfsg-4
- 2.6.0+dfsg-1
- 2.6.0+dfsg-1~exp1
- 2.6.0+dfsg-2
- 2.6.0+dfsg-3
- 2.6.0+dfsg-4
- 2.6.0+dfsg-5
- 2.6.0+dfsg-7
- 2.6.0+dfsg-8
- 2.6.0+dfsg-9
- 2.6.0~rc9+dfsg-1~exp1
- 2.9.0+dfsg-1~exp1
- 2.9.0+dfsg-1~exp2
- 2.9.1+dfsg-1~exp1
- 2.9.1+dfsg-1~exp2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pytorch Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.0+dfsg-1
Actualiza a 2.6.0+dfsg-1
pytorch Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.0+dfsg-1
Actualiza a 2.6.0+dfsg-1
torch PyPI
- Versiones
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.12.1
- 1.13.0
- 1.13.1
- 1.2.0
- 1.3.0
- 1.3.1
- 1.4.0
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.8.1
- 1.9.0
- 1.9.1
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.1
- 2.2.2
- 2.3.0
- 2.3.1
- 2.4.0
- 2.4.1
- 2.5.0
- 2.5.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.6.0
Actualiza a 2.6.0