CVE-2025-32990
CVE-2025-32990 · Gnutls: vulnerability in gnutls certtool template parsing
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A heap-buffer-overflow (off-by-one) flaw was found in the GnuTLS software in the template parsing logic within the certtool utility. When it reads certain settings from a template file, it allows an attacker to cause an out-of-bounds (OOB) NULL pointer write, resulting in memory corruption and a denial-of-service (DoS) that could potentially crash the system.
CVSS 6.5 · Media · EPSS 0,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
red hat enterprise linux 10
- Versiones
- ≥ 0:3.8.9-9.el10_0.14: No afectada (rpm)
Sin corrección publicada
red hat enterprise linux 8
- Versiones
- ≥ 0:3.6.16-8.el8_10.4: No afectada (rpm)
Sin corrección publicada
red hat enterprise linux 9
- Versiones
- ≥ 0:3.8.3-6.el9_6.2: No afectada (rpm)
Sin corrección publicada
red hat enterprise linux 9.2 update services for sap solutions
- Versiones
- ≥ 0:3.7.6-21.el9_2.4: No afectada (rpm)
Sin corrección publicada
red hat enterprise linux 9.4 extended update support
- Versiones
- ≥ 0:3.8.3-4.el9_4.4: No afectada (rpm)
Sin corrección publicada
red hat ceph storage 7
- Versiones
- ≥ 7: No afectada (rpm)
Sin corrección publicada
red hat discovery 2
- Versiones
- ≥ 2.3.0-1760554384: No afectada (rpm)
Sin corrección publicada
red hat hardened images
- Versiones
- ≥ 3.8.12-1.1.hum1: No afectada (rpm)
Sin corrección publicada
red hat insights proxy 1.5
- Versiones
- ≥ 1.5.7-1759331989: No afectada (rpm)
Sin corrección publicada
red hat enterprise linux 6
Sin corrección publicada
red hat enterprise linux 7
Sin corrección publicada
red hat openshift container platform 4
Sin corrección publicada
gnutls28 Debian:12
- Versiones
- 3.7.9-2
- 3.7.9-2+deb12u1
- 3.7.9-2+deb12u2
- 3.7.9-2+deb12u3
- 3.7.9-2+deb12u4
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.7.9-2+deb12u5
Actualiza a 3.7.9-2+deb12u5
gnutls28 Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.9-3
Actualiza a 3.8.9-3
gnutls28 Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.9-3
Actualiza a 3.8.9-3
gnutls28 Ubuntu:Pro:16.04:LTS
- Versiones
- 3.3.15-5ubuntu2
- 3.3.18-1ubuntu1
- 3.3.20-1ubuntu1
- 3.4.9-2ubuntu1
- 3.4.10-4ubuntu1
- 3.4.10-4ubuntu1.1
- 3.4.10-4ubuntu1.2
- 3.4.10-4ubuntu1.3
- 3.4.10-4ubuntu1.4
- 3.4.10-4ubuntu1.5
- 3.4.10-4ubuntu1.6
- 3.4.10-4ubuntu1.7
- 3.4.10-4ubuntu1.8
- 3.4.10-4ubuntu1.9
- 3.4.10-4ubuntu1.9+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.4.10-4ubuntu1.9+esm2
Actualiza a 3.4.10-4ubuntu1.9+esm2
gnutls28 Ubuntu:Pro:18.04:LTS
- Versiones
- 3.5.8-6ubuntu3
- 3.5.17-1ubuntu1
- 3.5.17-1ubuntu3
- 3.5.18-1ubuntu1
- 3.5.18-1ubuntu1.1
- 3.5.18-1ubuntu1.2
- 3.5.18-1ubuntu1.3
- 3.5.18-1ubuntu1.4
- 3.5.18-1ubuntu1.5
- 3.5.18-1ubuntu1.6
- 3.5.18-1ubuntu1.6+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.18-1ubuntu1.6+esm2
Actualiza a 3.5.18-1ubuntu1.6+esm2
gnutls28 Ubuntu:Pro:20.04:LTS
- Versiones
- 3.6.9-5ubuntu1
- 3.6.9-5ubuntu2
- 3.6.10-5
- 3.6.11.1-2
- 3.6.11.1-2ubuntu2
- 3.6.13-2ubuntu1
- 3.6.13-2ubuntu1.1
- 3.6.13-2ubuntu1.2
- 3.6.13-2ubuntu1.3
- 3.6.13-2ubuntu1.6
- 3.6.13-2ubuntu1.7
- 3.6.13-2ubuntu1.8
- 3.6.13-2ubuntu1.9
- 3.6.13-2ubuntu1.10
- 3.6.13-2ubuntu1.11
- 3.6.13-2ubuntu1.12
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.6.13-2ubuntu1.12+esm1
Actualiza a 3.6.13-2ubuntu1.12+esm1
gnutls28 Ubuntu:22.04:LTS
- Versiones
- 3.7.1-5ubuntu1
- 3.7.2-2ubuntu1
- 3.7.2-4ubuntu1
- 3.7.2-5ubuntu1
- 3.7.3-4ubuntu1
- 3.7.3-4ubuntu1.1
- 3.7.3-4ubuntu1.2
- 3.7.3-4ubuntu1.3
- 3.7.3-4ubuntu1.4
- 3.7.3-4ubuntu1.5
- 3.7.3-4ubuntu1.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.7.3-4ubuntu1.7
Actualiza a 3.7.3-4ubuntu1.7
gnutls28 Ubuntu:Pro:FIPS-preview:22.04:LTS
- Versiones
- 3.7.3-4ubuntu1.2+Fips1.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
gnutls28 Ubuntu:Pro:FIPS-updates:22.04:LTS
- Versiones
- 3.7.3-4ubuntu1.2+Fips1.1
- 3.7.3-4ubuntu1.3+Fips1.1
- 3.7.3-4ubuntu1.4+Fips1
- 3.7.3-4ubuntu1.5+Fips1
- 3.7.3-4ubuntu1.6+Fips1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.7.3-4ubuntu1.7+Fips1
Actualiza a 3.7.3-4ubuntu1.7+Fips1
gnutls28 Ubuntu:24.04:LTS
- Versiones
- 3.8.1-4ubuntu1
- 3.8.1-4ubuntu6
- 3.8.1-4ubuntu7
- 3.8.3-1ubuntu1
- 3.8.3-1.1ubuntu2
- 3.8.3-1.1ubuntu3
- 3.8.3-1.1ubuntu3.1
- 3.8.3-1.1ubuntu3.2
- 3.8.3-1.1ubuntu3.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.3-1.1ubuntu3.4
Actualiza a 3.8.3-1.1ubuntu3.4
gnutls28 Ubuntu:Pro:FIPS-updates:24.04:LTS
- Versiones
- 3.8.3-1.1ubuntu3.1+Fips1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.3-1.1ubuntu3.4+Fips1
Actualiza a 3.8.3-1.1ubuntu3.4+Fips1
gnutls28 Ubuntu:25.10
- Versiones
- 3.8.9-2ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.9-3ubuntu1
Actualiza a 3.8.9-3ubuntu1
Fuentes originales
- https://access.redhat.com/errata/RHSA-2025:16115
- https://access.redhat.com/errata/RHSA-2025:16116
- https://access.redhat.com/errata/RHSA-2025:17181
- https://access.redhat.com/errata/RHSA-2025:17348
- https://access.redhat.com/errata/RHSA-2025:17361
- https://access.redhat.com/errata/RHSA-2025:17415
- https://access.redhat.com/errata/RHSA-2025:19088
- https://access.redhat.com/errata/RHSA-2025:22529
- https://access.redhat.com/errata/RHSA-2026:7477
- https://access.redhat.com/security/cve/CVE-2025-32990
- https://bugzilla.redhat.com/show_bug.cgi?id=2359620
- https://lists.gnupg.org/pipermail/gnutls-help/2025-July/004883.html
- https://lists.debian.org/debian-lts-announce/2025/08/msg00005.html
- http://www.openwall.com/lists/oss-security/2025/07/11/3
- https://nvd.nist.gov/vuln/detail/CVE-2025-32990