p PatchFirst

CVE-2025-47275

CVE-2025-47275 · Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Auth0-PHP provides the PHP SDK for Auth0 Authentication and Management APIs. Starting in version 8.0.0-BETA1 and prior to version 8.14.0, session cookies of applications using the Auth0-PHP SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Certain pre-conditions are required to be vulnerable to this issue: Applications using the Auth0-PHP SDK, or the Auth0/symfony, Auth0/laravel-auth0, and Auth0/wordpress SDKs that rely on the Auth0-PHP SDK; and session storage configured with CookieStore. Upgrade Auth0/Auth0-PHP to v8.14.0 to receive a patch. As an additional precautionary measure, rotating cookie encryption keys is recommended. Note that once updated, any previous session cookies will be rejected.

CVSS 9.1 · Crítica · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • auth0-php

    Versiones
    • >= 8.0.0-BETA1, < 8.14.0: Afectada

    Sin corrección publicada

  • auth0/auth0-php Packagist

    Versiones
    • 8.0.0
    • 8.0.0-BETA1
    • 8.0.0-BETA2
    • 8.0.0-BETA3
    • 8.0.1
    • 8.0.2
    • 8.0.3
    • 8.0.4
    • 8.0.5
    • 8.0.6
    • 8.1.0
    • 8.10.0
    • 8.11.0
    • 8.11.1
    • 8.12.0
    • 8.13.0
    • 8.2.0
    • 8.2.1
    • 8.3.0
    • 8.3.1
    • 8.3.2
    • 8.3.3
    • 8.3.4
    • 8.3.5
    • 8.3.6
    • 8.3.7
    • 8.3.8
    • 8.4.0
    • 8.5.0
    • 8.6.0
    • 8.7.0
    • 8.7.1
    • 8.8.0
    • 8.9.0
    • 8.9.1
    • 8.9.3
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 8.0.0-BETA1, < 8.14.0

    Actualiza a 8.14.0

Fuentes originales

Comprueba tu servidor →