CVE-2025-48947
CVE-2025-48947 · NextJS-Auth0 SDK Vulnerable to CDN Caching of Session Cookies
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In Auth0 Next.js SDK versions 4.0.1 through 4.6.0, `__session` cookies set by auth0.middleware may be cached by CDNs due to missing Cache-Control headers. Three preconditions must be met in order for someone to be affected by the vulnerability: Applications using the NextJS-Auth0 SDK, versions between 4.0.1 to 4.6.0, applications using CDN or edge caching that caches responses with the Set-Cookie header, and if the Cache-Control header is not properly set for sensitive responses. Users should upgrade auth0/nextjs-auth0 to v4.6.1 to receive a patch.
CVSS 7.7 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
nextjs-auth0
- Versiones
- >= 4.0.1, < 4.6.1: Afectada
Sin corrección publicada
@auth0/nextjs-auth0 npm
- Intervalos de versiones afectados
- SEMVER: ≥ 4.0.1, < 4.6.1
Actualiza a 4.6.1