p PatchFirst

CVE-2025-54068

CVE-2025-54068 · Livewire vulnerable to remote command execution during property update hydration

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.

CVSS 9.2 · Crítica · EPSS 96,3% · En el catálogo KEV · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • livewire

    Versiones
    • >= 3.0.0-beta.1, < 3.6.4: Afectada

    Sin corrección publicada

  • livewire/livewire Packagist

    Versiones
    • v3.0.0
    • v3.0.0-beta.1
    • v3.0.0-beta.10
    • v3.0.0-beta.11
    • v3.0.0-beta.2
    • v3.0.0-beta.3
    • v3.0.0-beta.4
    • v3.0.0-beta.5
    • v3.0.0-beta.6
    • v3.0.0-beta.7
    • v3.0.0-beta.8
    • v3.0.0-beta.9
    • v3.0.1
    • v3.0.10
    • v3.0.2
    • v3.0.3
    • v3.0.4
    • v3.0.5
    • v3.0.6
    • v3.0.7
    • v3.0.8
    • v3.0.9
    • v3.1.0
    • v3.2.0
    • v3.2.1
    • v3.2.2
    • v3.2.3
    • v3.2.4
    • v3.2.5
    • v3.2.6
    • v3.3.0
    • v3.3.1
    • v3.3.2
    • v3.3.3
    • v3.3.4
    • v3.3.5
    • v3.4.0
    • v3.4.1
    • v3.4.10
    • v3.4.11
    • v3.4.12
    • v3.4.2
    • v3.4.3
    • v3.4.4
    • v3.4.5
    • v3.4.6
    • v3.4.7
    • v3.4.8
    • v3.4.9
    • v3.5.0
    • v3.5.1
    • v3.5.10
    • v3.5.11
    • v3.5.12
    • v3.5.13
    • v3.5.14
    • v3.5.15
    • v3.5.16
    • v3.5.17
    • v3.5.18
    • v3.5.19
    • v3.5.2
    • v3.5.20
    • v3.5.3
    • v3.5.4
    • v3.5.5
    • v3.5.6
    • v3.5.7
    • v3.5.8
    • v3.5.9
    • v3.6.0
    • v3.6.1
    • v3.6.2
    • v3.6.3
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 3.0.0-beta.1, < 3.6.4

    Actualiza a 3.6.4

Fuentes originales

Comprueba tu servidor →