CVE-2025-54389
CVE-2025-54389 · AIDE improper output neutralization vulnerability
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
AIDE is an advanced intrusion detection environment. Prior to version 0.19.2, there is an improper output neutralization vulnerability in AIDE. An attacker can craft a malicious filename by including terminal escape sequences to hide the addition or removal of the file from the report and/or tamper with the log output. A local user might exploit this to bypass the AIDE detection of malicious files. Additionally the output of extended attribute key names and symbolic links targets are also not properly neutralized. This issue has been patched in version 0.19.2. A workaround involves configuring AIDE to write the report output to a regular file, redirecting stdout to a regular file, or redirecting the log output written to stderr to a regular file.
CVSS 6.2 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
aide
- Versiones
- < 0.19.2: Afectada
Sin corrección publicada
aide Debian:12
- Versiones
- 0.18.3-1
- 0.18.3-1+deb12u1
- 0.18.3-1+deb12u2
- 0.18.3-1+deb12u3
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.3-1+deb12u4
Actualiza a 0.18.3-1+deb12u4
aide Debian:13
- Versiones
- 0.19.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.19.1-2+deb13u1
Actualiza a 0.19.1-2+deb13u1
aide Debian:14
- Versiones
- 0.19.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.19.2-1
Actualiza a 0.19.2-1
aide Ubuntu:Pro:14.04:LTS
- Versiones
- 0.15.1-8ubuntu2
- 0.16~a2.git20130520-2
- 0.16~a2.git20130520-2ubuntu0.1
- 0.16~a2.git20130520-2ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16~a2.git20130520-2ubuntu0.1+esm2
Actualiza a 0.16~a2.git20130520-2ubuntu0.1+esm2
aide Ubuntu:Pro:16.04:LTS
- Versiones
- 0.16~a2.git20130520-3
- 0.16~a2.git20130520-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16~a2.git20130520-3ubuntu0.1~esm2
Actualiza a 0.16~a2.git20130520-3ubuntu0.1~esm2
aide Ubuntu:Pro:18.04:LTS
- Versiones
- 0.16-1
- 0.16-2
- 0.16-3
- 0.16-3ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16-3ubuntu0.1+esm1
Actualiza a 0.16-3ubuntu0.1+esm1
aide Ubuntu:Pro:20.04:LTS
- Versiones
- 0.16.1-1build2
- 0.16.1-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.16.1-1ubuntu0.1+esm1
Actualiza a 0.16.1-1ubuntu0.1+esm1
aide Ubuntu:22.04:LTS
- Versiones
- 0.17.3-4build1
- 0.17.3-5
- 0.17.4-1
- 0.17.4-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.17.4-1ubuntu0.2
Actualiza a 0.17.4-1ubuntu0.2
aide Ubuntu:24.04:LTS
- Versiones
- 0.18.5-1
- 0.18.6-2
- 0.18.6-2build1
- 0.18.6-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.18.6-2ubuntu0.1
Actualiza a 0.18.6-2ubuntu0.1
Fuentes originales
- https://github.com/aide/aide/security/advisories/GHSA-522j-vvx9-gg28
- https://github.com/aide/aide/commit/64c8f32b0349c33fb8382784af468338078851f9
- https://github.com/aide/aide/releases/tag/v0.19.2
- https://lists.debian.org/debian-lts-announce/2025/08/msg00011.html
- http://www.openwall.com/lists/oss-security/2025/08/14/7
- https://nvd.nist.gov/vuln/detail/CVE-2025-54389