p PatchFirst

CVE-2025-55674

CVE-2025-55674 · Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

A bypass of the DISALLOWED_SQL_FUNCTIONS security feature in Apache Superset allows for the execution of blocked SQL functions. An attacker can use a special inline block to circumvent the denylist. This allows a user with SQL Lab access to execute functions that were intended to be disabled, leading to the disclosure of sensitive database information like the software version. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

CVSS 5.3 · Media · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache superset

    Versiones
    • ≥ 0, < 5.0.0: Afectada (semver)

    Actualiza a 5.0.0

  • apache-superset PyPI

    Versiones
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.1.0rc1
    • 3.1.0rc2
    • 3.1.0rc3
    • 3.1.0rc4
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 4.0.0
    • 4.0.0rc1
    • 4.0.0rc2
    • 4.0.1
    • 4.0.2
    • 4.1.0
    • 4.1.0rc2
    • 4.1.0rc3
    • 4.1.0rc4
    • 4.1.1
    • 4.1.1rc1
    • 4.1.2
    • 4.1.2rc1
    • 4.1.3.post1
    • 4.1.3rc1
    • 4.1.3rc2
    • 4.1.4
    • 4.1.4rc1
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.0.0rc3
    • 5.0.0rc4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.0.0

    Actualiza a 5.0.0

Fuentes originales

Comprueba tu servidor →