p PatchFirst

CVE-2025-55754

CVE-2025-55754 · Apache Tomcat: console manipulation via escape sequences in log messages

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

CVSS 9.6 · Crítica · EPSS 10,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • apache tomcat

    Versiones
    • ≥ 11.0.0-M1, ≤ 11.0.10: Afectada (semver)
    • ≥ 10.1.0-M1, ≤ 10.1.44: Afectada (semver)
    • ≥ 9.0.40, ≤ 9.0.108: Afectada (semver)
    • ≥ 8.5.60, ≤ 8.5.100: Afectada (semver)
    • ≥ 3, < 8.5.0: Desconocido (semver)
    • ≥ 10.0.0-M1, ≤ 10.0.27: Desconocido (semver)

    Sin corrección publicada

  • tomcat10 Debian:12

    Versiones
    • 10.1.10-1
    • 10.1.13-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.20-1
    • 10.1.23-1
    • 10.1.25-1
    • 10.1.25-1~bpo12+1
    • 10.1.25-2
    • 10.1.30-1
    • 10.1.30-1~bpo12+1
    • 10.1.31-1
    • 10.1.33-1
    • 10.1.33-1~bpo12+1
    • 10.1.34-0+deb12u1
    • 10.1.34-0+deb12u2
    • 10.1.34-1
    • 10.1.35-1
    • 10.1.40-1
    • 10.1.40-1~bpo12+1
    • 10.1.46-1
    • 10.1.6-1
    • 10.1.6-1+deb12u1
    • 10.1.6-1+deb12u2
    • 10.1.7-1
    • 10.1.8-1
    • 10.1.9-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 10.1.52-1~deb12u1

    Actualiza a 10.1.52-1~deb12u1

  • tomcat10 Debian:13

    Versiones
    • 10.1.40-1
    • 10.1.46-1
    • 10.1.52-1~deb12u1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 10.1.52-1~deb13u1

    Actualiza a 10.1.52-1~deb13u1

  • tomcat10 Debian:14

    Versiones
    • 10.1.40-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 10.1.46-1

    Actualiza a 10.1.46-1

  • tomcat11 Debian:13

    Versiones
    • 11.0.11-1
    • 11.0.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 11.0.15-1~deb13u1

    Actualiza a 11.0.15-1~deb13u1

  • tomcat11 Debian:14

    Versiones
    • 11.0.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 11.0.11-1

    Actualiza a 11.0.11-1

  • tomcat9 Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2

    Actualiza a 9.0.70-2

  • tomcat9 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2

    Actualiza a 9.0.70-2

  • tomcat9 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 9.0.70-2

    Actualiza a 9.0.70-2

  • tomcat9 Ubuntu:Pro:22.04:LTS

    Versiones
    • 9.0.43-3
    • 9.0.54-1
    • 9.0.55-1
    • 9.0.58-1
    • 9.0.58-1ubuntu0.1
    • 9.0.58-1ubuntu0.1+esm1
    • 9.0.58-1ubuntu0.1+esm2
    • 9.0.58-1ubuntu0.1+esm3
    • 9.0.58-1ubuntu0.1+esm4
    • 9.0.58-1ubuntu0.2
    • 9.0.58-1ubuntu0.2+esm1
    • 9.0.58-1ubuntu0.2+esm2
    • 9.0.58-1ubuntu0.2+esm3
    • 9.0.58-1ubuntu0.2+esm4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • tomcat10 Ubuntu:24.04:LTS

    Versiones
    • 10.1.10-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.16-1ubuntu0.1~esm1
    • 10.1.16-1ubuntu0.1~esm2
    • 10.1.16-1ubuntu0.1~esm3
    • 10.1.16-1ubuntu0.1~esm4
    • 10.1.55-1ubuntu2~24.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • tomcat10 Ubuntu:25.10

    Versiones
    • 10.1.35-1
    • 10.1.40-1
    • 10.1.40-1ubuntu1
    • 10.1.40-1ubuntu1.25.10.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • tomcat11 Ubuntu:25.10

    Versiones
    • 11.0.6-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • tomcat10 Ubuntu:26.04:LTS

    Versiones
    • 10.1.40-1ubuntu1
    • 10.1.40-1ubuntu1.26.04.1
    • 10.1.55-1ubuntu2~26.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →