CVE-2025-58068
CVE-2025-58068 · Eventlet affected by HTTP request smuggling in unparsed trailers
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Eventlet is a concurrent networking library for Python. Prior to version 0.40.3, the Eventlet WSGI parser is vulnerable to HTTP Request Smuggling due to improper handling of HTTP trailer sections. This vulnerability could enable attackers to, bypass front-end security controls, launch targeted attacks against active site users, and poison web caches. This problem has been patched in Eventlet 0.40.3 by dropping trailers which is a breaking change if a backend behind eventlet.wsgi proxy requires trailers. A workaround involves not using eventlet.wsgi facing untrusted clients.
CVSS 6.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
eventlet
- Versiones
- < 0.40.3: Afectada
Sin corrección publicada
python-eventlet Debian:12
- Versiones
- 0.33.1-4
- 0.33.3-1
- 0.33.3-2
- 0.33.3-2.1
- 0.33.3-3
- 0.35.1-1
- 0.35.1-2
- 0.35.1-3
- 0.36.1-1
- 0.36.1-10
- 0.36.1-11
- 0.36.1-12
- 0.36.1-2
- 0.36.1-3
- 0.36.1-4
- 0.36.1-5
- 0.36.1-6
- 0.36.1-7
- 0.36.1-8
- 0.36.1-9
- 0.39.1-1
- 0.39.1-2
- 0.40.1-1
- 0.40.1-2
- 0.40.1-3
- 0.40.2-1
- 0.40.3-1
- 0.40.3-2
- 0.40.4-1
- 0.40.4-2
- 0.40.4-3
- 0.40.4-4
- 0.41.2-1
- 0.41.2-2
- 0.41.2-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-eventlet Debian:13
- Versiones
- 0.39.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.39.1-2+deb13u1
Actualiza a 0.39.1-2+deb13u1
python-eventlet Debian:14
- Versiones
- 0.39.1-2
- 0.40.1-1
- 0.40.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.40.1-3
Actualiza a 0.40.1-3
eventlet PyPI
- Versiones
- 0.10.0
- 0.11.0
- 0.12.1
- 0.13.0
- 0.14.0
- 0.15.2
- 0.16.1
- 0.17.4
- 0.18.2
- 0.18.3
- 0.18.4
- 0.19.0
- 0.2
- 0.20.0
- 0.20.1
- 0.21.0
- 0.22.0
- 0.22.1
- 0.23.0
- 0.24.0
- 0.24.1
- 0.25.0
- 0.25.1
- 0.25.2
- 0.26.0
- 0.26.1
- 0.27.0
- 0.28.0
- 0.28.1
- 0.29.0
- 0.29.1
- 0.30.0
- 0.30.1
- 0.30.2
- 0.30.3
- 0.31.0
- 0.31.1
- 0.32.0
- 0.33.0
- 0.33.1
- 0.33.2
- 0.33.3
- 0.34.1
- 0.34.2
- 0.34.3
- 0.35.0
- 0.35.1
- 0.35.2
- 0.36.0
- 0.36.1
- 0.37.0
- 0.38.0
- 0.38.1
- 0.38.2
- 0.39.0
- 0.39.1
- 0.40.0
- 0.40.1
- 0.40.2
- 0.5.3
- 0.6.1
- 0.7
- 0.8
- 0.8.16
- 0.9.17
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.40.3
Actualiza a 0.40.3
python-eventlet Ubuntu:16.04:LTS
- Versiones
- 0.17.4-2ubuntu1
- 0.18.4-1ubuntu1
- 0.18.4-1ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-eventlet Ubuntu:18.04:LTS
- Versiones
- 0.19.0-7
- 0.20.0-2~build1
- 0.20.0-2ubuntu1
- 0.20.0-2ubuntu2
- 0.20.0-3
- 0.20.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-eventlet Ubuntu:Pro:20.04:LTS
- Versiones
- 0.25.0-0ubuntu1
- 0.25.1-2build1
- 0.25.1-2ubuntu1
- 0.25.1-2ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.25.1-2ubuntu1.1+esm2
Actualiza a 0.25.1-2ubuntu1.1+esm2
python-eventlet Ubuntu:22.04:LTS
- Versiones
- 0.30.2-0ubuntu1
- 0.30.2-0ubuntu2
- 0.30.2-5ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.30.2-5ubuntu2.2
Actualiza a 0.30.2-5ubuntu2.2
python-eventlet Ubuntu:24.04:LTS
- Versiones
- 0.33.1-4ubuntu1
- 0.33.1-4ubuntu2
- 0.35.1-0ubuntu1
- 0.35.1-0ubuntu2
- 0.35.2-0ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.35.2-0ubuntu1.1
Actualiza a 0.35.2-0ubuntu1.1
python-eventlet Ubuntu:25.10
- Versiones
- 0.39.0-0ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.39.0-0ubuntu2
Actualiza a 0.39.0-0ubuntu2
python-eventlet Ubuntu:26.04:LTS
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.39.0-0ubuntu2
Actualiza a 0.39.0-0ubuntu2
Fuentes originales
- https://github.com/eventlet/eventlet/security/advisories/GHSA-hw6f-rjfj-j7j7
- https://github.com/eventlet/eventlet/pull/1062
- https://github.com/eventlet/eventlet/commit/0bfebd1117d392559e25b4bfbfcc941754de88fb
- https://lists.debian.org/debian-lts-announce/2025/09/msg00003.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-58068