CVE-2025-58436
CVE-2025-58436 · OpenPrinting CUPS slow client can halt cupsd, leading to a possible DoS attack
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. Prior to version 2.4.15, a client that connects to cupsd but sends slow messages, e.g. only one byte per second, delays cupsd as a whole, such that it becomes unusable by other clients. This issue has been patched in version 2.4.15.
CVSS 5.1 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
cups
- Versiones
- < 2.4.15: Afectada
Sin corrección publicada
cups Debian:12
- Versiones
- 2.4.10-1
- 2.4.10-2
- 2.4.10-3
- 2.4.10-4
- 2.4.14-1
- 2.4.15-1
- 2.4.16-1
- 2.4.17-1
- 2.4.18-1
- 2.4.2-3
- 2.4.2-3+deb12u1
- 2.4.2-3+deb12u2
- 2.4.2-3+deb12u3
- 2.4.2-3+deb12u4
- 2.4.2-3+deb12u5
- 2.4.2-3+deb12u6
- 2.4.2-3+deb12u7
- 2.4.2-3+deb12u8
- 2.4.2-3+deb12u9
- 2.4.2-4
- 2.4.2-5
- 2.4.2-6
- 2.4.7-1
- 2.4.7-1.1
- 2.4.7-1.2
- 2.4.7-2
- 2.4.7-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cups Debian:13
- Versiones
- 2.4.10-3
- 2.4.10-3+deb13u1
- 2.4.10-3+deb13u2
- 2.4.10-4
- 2.4.14-1
- 2.4.15-1
- 2.4.16-1
- 2.4.17-1
- 2.4.18-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
cups Debian:14
- Versiones
- 2.4.10-3
- 2.4.10-4
- 2.4.14-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.15-1
Actualiza a 2.4.15-1
cups Ubuntu:Pro:16.04:LTS
- Versiones
- 2.1.0-4ubuntu3
- 2.1.0-5
- 2.1.0-6
- 2.1.0-6ubuntu1
- 2.1.0-7
- 2.1.2-1
- 2.1.2-2
- 2.1.3-1
- 2.1.3-1build1
- 2.1.3-3
- 2.1.3-4
- 2.1.3-4ubuntu0.2
- 2.1.3-4ubuntu0.3
- 2.1.3-4ubuntu0.4
- 2.1.3-4ubuntu0.5
- 2.1.3-4ubuntu0.6
- 2.1.3-4ubuntu0.7
- 2.1.3-4ubuntu0.8
- 2.1.3-4ubuntu0.9
- 2.1.3-4ubuntu0.10
- 2.1.3-4ubuntu0.11
- 2.1.3-4ubuntu0.11+esm1
- 2.1.3-4ubuntu0.11+esm2
- 2.1.3-4ubuntu0.11+esm3
- 2.1.3-4ubuntu0.11+esm4
- 2.1.3-4ubuntu0.11+esm5
- 2.1.3-4ubuntu0.11+esm6
- 2.1.3-4ubuntu0.11+esm7
- 2.1.3-4ubuntu0.11+esm8
- 2.1.3-4ubuntu0.11+esm9
- 2.1.3-4ubuntu0.11+esm11
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.3-4ubuntu0.11+esm12
Actualiza a 2.1.3-4ubuntu0.11+esm12
cups Ubuntu:Pro:18.04:LTS
- Versiones
- 2.2.4-7ubuntu2
- 2.2.5-2
- 2.2.6-2
- 2.2.6-3
- 2.2.6-4
- 2.2.6-5
- 2.2.7-1ubuntu1
- 2.2.7-1ubuntu2
- 2.2.7-1ubuntu2.1
- 2.2.7-1ubuntu2.2
- 2.2.7-1ubuntu2.3
- 2.2.7-1ubuntu2.4
- 2.2.7-1ubuntu2.5
- 2.2.7-1ubuntu2.6
- 2.2.7-1ubuntu2.7
- 2.2.7-1ubuntu2.8
- 2.2.7-1ubuntu2.9
- 2.2.7-1ubuntu2.10
- 2.2.7-1ubuntu2.10+esm1
- 2.2.7-1ubuntu2.10+esm2
- 2.2.7-1ubuntu2.10+esm3
- 2.2.7-1ubuntu2.10+esm4
- 2.2.7-1ubuntu2.10+esm5
- 2.2.7-1ubuntu2.10+esm6
- 2.2.7-1ubuntu2.10+esm7
- 2.2.7-1ubuntu2.10+esm9
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.2.7-1ubuntu2.10+esm10
Actualiza a 2.2.7-1ubuntu2.10+esm10
cups Ubuntu:Pro:20.04:LTS
- Versiones
- 2.2.12-2ubuntu1
- 2.3.0-6
- 2.3.0-7
- 2.3.0-7ubuntu1
- 2.3.1-1ubuntu1
- 2.3.1-2
- 2.3.1-4
- 2.3.1-7
- 2.3.1-9ubuntu1
- 2.3.1-9ubuntu1.1
- 2.3.1-9ubuntu1.2
- 2.3.1-9ubuntu1.3
- 2.3.1-9ubuntu1.4
- 2.3.1-9ubuntu1.5
- 2.3.1-9ubuntu1.6
- 2.3.1-9ubuntu1.7
- 2.3.1-9ubuntu1.8
- 2.3.1-9ubuntu1.9
- 2.3.1-9ubuntu1.9+esm1
- 2.3.1-9ubuntu1.9+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.1-9ubuntu1.9+esm4
Actualiza a 2.3.1-9ubuntu1.9+esm4
cups Ubuntu:22.04:LTS
- Versiones
- 2.3.3op2-7ubuntu2
- 2.4.1op1-1ubuntu1
- 2.4.1op1-1ubuntu2
- 2.4.1op1-1ubuntu3
- 2.4.1op1-1ubuntu4
- 2.4.1op1-1ubuntu4.1
- 2.4.1op1-1ubuntu4.2
- 2.4.1op1-1ubuntu4.4
- 2.4.1op1-1ubuntu4.6
- 2.4.1op1-1ubuntu4.7
- 2.4.1op1-1ubuntu4.8
- 2.4.1op1-1ubuntu4.9
- 2.4.1op1-1ubuntu4.10
- 2.4.1op1-1ubuntu4.11
- 2.4.1op1-1ubuntu4.12
- 2.4.1op1-1ubuntu4.15
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.1op1-1ubuntu4.16
Actualiza a 2.4.1op1-1ubuntu4.16
cups Ubuntu:24.04:LTS
- Versiones
- 2.4.6-0ubuntu3
- 2.4.7-1.2ubuntu2
- 2.4.7-1.2ubuntu3
- 2.4.7-1.2ubuntu7
- 2.4.7-1.2ubuntu7.1
- 2.4.7-1.2ubuntu7.2
- 2.4.7-1.2ubuntu7.3
- 2.4.7-1.2ubuntu7.4
- 2.4.7-1.2ubuntu7.7
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.7-1.2ubuntu7.9
Actualiza a 2.4.7-1.2ubuntu7.9
cups Ubuntu:25.10
- Versiones
- 2.4.12-0ubuntu1
- 2.4.12-0ubuntu2
- 2.4.12-0ubuntu3
- 2.4.12-0ubuntu3.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.12-0ubuntu3.5
Actualiza a 2.4.12-0ubuntu3.5
Fuentes originales
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-8wpw-vfgm-qrrr
- https://github.com/OpenPrinting/cups/commit/40008d76a001babbb9beb9d9d74b01a86fb6ddb4
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.15
- http://www.openwall.com/lists/oss-security/2025/11/27/4
- https://nvd.nist.gov/vuln/detail/CVE-2025-58436