CVE-2025-59142
CVE-2025-59142 · [email protected] contains malware after npm account takeover
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
color-string is a parser and generator for CSS color strings. On 8 September 2025, the npm publishing account for color-string was taken over after a phishing attack. Version 2.1.1 was published, functionally identical to the previous patch version, but with a malware payload added attempting to redirect cryptocurrency transactions to the attacker's own addresses from within browser environments. Local environments, server environments, command line applications, etc. are not affected. If the package was used in a browser context (e.g. a direct <script> inclusion, or via a bundling tool such as Babel, Rollup, Vite, Next.js, etc.) there is a chance the malware still exists and such bundles will need to be rebuilt. The malware seemingly only targets cryptocurrency transactions and wallets such as MetaMask. npm removed the offending package from the registry over the course of the day on 8 September. On 13 September, the package owner published new patch versions to help cache-bust those using private registries who might still have the compromised version cached. This issue has been resolved in 2.1.2.
CVSS 8.8 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
color-string
- Versiones
- = 2.1.1: Afectada
Sin corrección publicada
color-string npm
- Versiones
- 2.1.1
- Intervalos de versiones afectados
- SEMVER: ≥ 2.1.1, < 2.1.2
Actualiza a 2.1.2
color-string npm
- Versiones
- 2.1.1
Sin corrección publicada
Fuentes originales
- https://github.com/Qix-/color-string/security/advisories/GHSA-286p-vc9p-p5qv
- https://github.com/debug-js/debug/issues/1005
- https://socket.dev/blog/npm-author-qix-compromised-in-major-supply-chain-attack
- https://www.aikido.dev/blog/npm-debug-and-chalk-packages-compromised
- https://www.ox.security/blog/npm-packages-compromised
- https://nvd.nist.gov/vuln/detail/CVE-2025-59142