CVE-2025-61765
CVE-2025-61765 · python-socketio vulnerable to arbitrary Python code execution (RCE) through malicious pickle deserialization in certain multi-server deployments
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
python-socketio is a Python implementation of the Socket.IO realtime client and server. A remote code execution vulnerability in python-socketio versions prior to 5.14.0 allows attackers to execute arbitrary Python code through malicious pickle deserialization in multi-server deployments on which the attacker previously gained access to the message queue that the servers use for internal communications. When Socket.IO servers are configured to use a message queue backend such as Redis for inter-server communication, messages sent between the servers are encoded using the `pickle` Python module. When a server receives one of these messages through the message queue, it assumes it is trusted and immediately deserializes it. The vulnerability stems from deserialization of messages using Python's `pickle.loads()` function. Having previously obtained access to the message queue, the attacker can send a python-socketio server a crafted pickle payload that executes arbitrary code during deserialization via Python's `__reduce__` method. This vulnerability only affects deployments with a compromised message queue. The attack can lead to the attacker executing random code in the context of, and with the privileges of a Socket.IO server process. Single-server systems that do not use a message queue, and multi-server systems with a secure message queue are not vulnerable. In addition to making sure standard security practices are followed in the deployment of the message queue, users of the python-socketio package can upgrade to version 5.14.0 or newer, which remove the `pickle` module and use the much safer JSON encoding for inter-server messaging.
CVSS 6.4 · Media · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
python-socketio
- Versiones
- >= 0.8.0, < 5.14.0: Afectada
Sin corrección publicada
python-socketio Debian:12
- Versiones
- 5.11.2-1
- 5.11.2-1.1
- 5.12.1-1
- 5.13.0-1
- 5.16.0-1
- 5.17.0-1
- 5.7.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-socketio Debian:13
- Versiones
- 5.12.1-1
- 5.13.0-1
- 5.16.0-1
- 5.17.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-socketio Debian:14
- Versiones
- 5.12.1-1
- 5.13.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.16.0-1
Actualiza a 5.16.0-1
python-socketio PyPI
- Versiones
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.0
- 0.9.1
- 0.9.2
- 1.0
- 1.1
- 1.2
- 1.3
- 1.4
- 1.4.1
- 1.4.2
- 1.4.3
- 1.4.4
- 1.5.0
- 1.5.1
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.7.5
- 1.7.6
- 1.7.7
- 1.8.0
- 1.8.1
- 1.8.2
- 1.8.3
- 1.8.4
- 1.9.0
- 2.0.0
- 2.1.0
- 2.1.1
- 2.1.2
- 3.0.0
- 3.0.1
- 3.1.0
- 3.1.1
- 3.1.2
- 4.0.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.1.0
- 4.2.0
- 4.2.1
- 4.3.0
- 4.3.1
- 4.4.0
- 4.5.0
- 4.5.1
- 4.6.0
- 4.6.1
- 5.0.0
- 5.0.1
- 5.0.2
- 5.0.3
- 5.0.4
- 5.1.0
- 5.10.0
- 5.11.0
- 5.11.1
- 5.11.2
- 5.11.3
- 5.11.4
- 5.12.0
- 5.12.1
- 5.13.0
- 5.2.0
- 5.2.1
- 5.3.0
- 5.4.0
- 5.4.1
- 5.5.0
- 5.5.1
- 5.5.2
- 5.6.0
- 5.7.0
- 5.7.1
- 5.7.2
- 5.8.0
- 5.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.8.0, < 5.14.0
Actualiza a 5.14.0
python-socketio Ubuntu:20.04:LTS
- Versiones
- 4.4.0-1
- 4.4.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-socketio Ubuntu:22.04:LTS
- Versiones
- 5.0.3-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-socketio Ubuntu:24.04:LTS
- Versiones
- 5.7.2-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-socketio Ubuntu:25.10
- Versiones
- 5.12.1-1
- 5.13.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-socketio Ubuntu:26.10
- Versiones
- 5.16.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-socketio Ubuntu:26.04:LTS
- Versiones
- 5.13.0-1
- 5.16.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/miguelgrinberg/python-socketio/security/advisories/GHSA-g8c6-8fjj-2r4m
- https://github.com/miguelgrinberg/python-socketio/commit/53f6be094257ed81476b0e212c8cddd6d06ca39a
- https://www.bluerock.io/post/cve-2025-61765-bluerock-discovers-critical-rce-in-socket-io-ecosystem
- https://nvd.nist.gov/vuln/detail/CVE-2025-61765