CVE-2025-62593
CVE-2025-62593 · Ray is vulnerable to RCE via Safari & Firefox Browsers through DNS Rebinding Attack
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Ray is an AI compute engine. Prior to version 2.52.0, developers working with Ray as a development tool can be exploited via a critical RCE vulnerability exploitable via Firefox and Safari. This vulnerability is due to an insufficient guard against browser-based attacks, as the current defense uses the User-Agent header starting with the string "Mozilla" as a defense mechanism. This defense is insufficient as the fetch specification allows the User-Agent header to be modified. Combined with a DNS rebinding attack against the browser, and this vulnerability is exploitable against a developer running Ray who inadvertently visits a malicious website, or is served a malicious advertisement (malvertising). This issue has been patched in version 2.52.0.
CVSS 9.4 · Crítica · EPSS 60,2% · En el catálogo KEV · Código de explotación público · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
ray
- Versiones
- < 2.52.0: Afectada
Sin corrección publicada
ray PyPI
- Versiones
- 0.1.1
- 0.1.2
- 0.2.0
- 0.2.1
- 0.2.2
- 0.3.0
- 0.3.1
- 0.4.0
- 0.5.0
- 0.5.2
- 0.5.3
- 0.6.0
- 0.6.1
- 0.6.2
- 0.6.3
- 0.6.4
- 0.6.5
- 0.6.6
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.7.4
- 0.7.5
- 0.7.6
- 0.7.7
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.8.5
- 0.8.6
- 0.8.7
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.11.0
- 1.11.1
- 1.12.0
- 1.12.1
- 1.13.0
- 1.2.0
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.5.2
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 1.9.1
- 1.9.2
- 2.0.0
- 2.0.1
- 2.1.0
- 2.10.0
- 2.11.0
- 2.12.0
- 2.2.0
- 2.20.0
- 2.21.0
- 2.22.0
- 2.23.0
- 2.24.0
- 2.3.0
- 2.3.0rc0
- 2.3.1
- 2.30.0
- 2.31.0
- 2.32.0
- 2.32.0rc0
- 2.33.0
- 2.34.0
- 2.35.0
- 2.36.0
- 2.36.1
- 2.37.0
- 2.38.0
- 2.39.0
- 2.4.0
- 2.40.0
- 2.41.0
- 2.42.0
- 2.42.1
- 2.43.0
- 2.44.0
- 2.44.1
- 2.45.0
- 2.46.0
- 2.47.0
- 2.47.1
- 2.48.0
- 2.49.0
- 2.49.1
- 2.49.2
- 2.5.0
- 2.5.1
- 2.50.0
- 2.50.1
- 2.51.0
- 2.51.1
- 2.51.2
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.7.0
- 2.7.0rc0
- 2.7.1
- 2.7.2
- 2.8.0
- 2.8.1
- 2.9.0
- 2.9.1
- 2.9.2
- 2.9.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.52.0
Actualiza a 2.52.0
Fuentes originales
- https://github.com/ray-project/ray/security/advisories/GHSA-q279-jhrf-cc6v
- https://github.com/ray-project/ray/commit/70e7c72780bdec075dba6cad1afe0832772bfe09
- https://www.bitsight.com/blog/rondodox-botnet-infrastructure-analysis
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-62593
- https://nvd.nist.gov/vuln/detail/CVE-2025-62593