p PatchFirst

CVE-2025-62707

CVE-2025-62707 · pypdf affected by possible infinite loop when reading DCT inline images without EOF marker

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

pypdf is a free and open-source pure-python PDF library. Prior to version 6.1.3, an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires parsing the content stream of a page which has an inline image using the DCTDecode filter. This has been fixed in pypdf version 6.1.3.

CVSS 6.6 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • pypdf

    Versiones
    • < 6.1.3: Afectada

    Sin corrección publicada

  • pypdf Debian:13

    Versiones
    • 5.4.0-1
    • 6.19.0-1
    • 6.9.0-1
    • 6.9.2-1
    • 6.9.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pypdf Debian:14

    Versiones
    • 5.4.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 6.9.0-1

    Actualiza a 6.9.0-1

  • pypdf PyPI

    Versiones
    • 1.0
    • 1.1
    • 1.10
    • 1.11
    • 1.12
    • 1.13
    • 1.2
    • 1.3
    • 1.4
    • 1.5
    • 1.6
    • 1.7
    • 1.8
    • 1.9
    • 3.1.0
    • 3.10.0
    • 3.11.0
    • 3.11.1
    • 3.12.0
    • 3.12.1
    • 3.12.2
    • 3.13.0
    • 3.14.0
    • 3.15.0
    • 3.15.1
    • 3.15.2
    • 3.15.3
    • 3.15.4
    • 3.15.5
    • 3.16.0
    • 3.16.1
    • 3.16.2
    • 3.16.3
    • 3.16.4
    • 3.17.0
    • 3.17.1
    • 3.17.2
    • 3.17.3
    • 3.17.4
    • 3.2.0
    • 3.2.1
    • 3.3.0
    • 3.4.0
    • 3.4.1
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.6.0
    • 3.7.0
    • 3.7.1
    • 3.8.0
    • 3.8.1
    • 3.9.0
    • 3.9.1
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.1.0
    • 4.2.0
    • 4.3.0
    • 4.3.1
    • 5.0.0
    • 5.0.1
    • 5.1.0
    • 5.2.0
    • 5.3.0
    • 5.3.1
    • 5.4.0
    • 5.5.0
    • 5.6.0
    • 5.6.1
    • 5.7.0
    • 5.8.0
    • 5.9.0
    • 6.0.0
    • 6.1.0
    • 6.1.1
    • 6.1.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 6.1.3

    Actualiza a 6.1.3

  • pypdf Ubuntu:24.04:LTS

    Versiones
    • 3.4.1-1
    • 3.17.4-1
    • 4.0.0-1
    • 4.0.1-1
    • 4.0.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pypdf Ubuntu:25.10

    Versiones
    • 4.3.1-1
    • 5.4.0-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pypdf Ubuntu:26.10

    Versiones
    • 6.9.2-1
    • 6.9.2-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pypdf Ubuntu:26.04:LTS

    Versiones
    • 5.4.0-1
    • 6.9.2-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →