p PatchFirst

CVE-2025-62718

CVE-2025-62718 · Axios has a NO_PROXY Hostname Normalization Bypass that Leads to SSRF

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.0 and 0.31.0, Axios does not correctly handle hostname normalization when checking NO_PROXY rules. Requests to loopback addresses like localhost. (with a trailing dot) or [::1] (IPv6 literal) skip NO_PROXY matching and go through the configured proxy. This goes against what developers expect and lets attackers force requests through a proxy, even if NO_PROXY is set up to protect loopback or internal services. This issue leads to the possibility of proxy bypass and SSRF vulnerabilities allowing attackers to reach sensitive loopback or internal services despite the configured protections. This vulnerability is fixed in 1.15.0 and 0.31.0.

CVSS 6.3 · Media · EPSS 1,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • axios

    Versiones
    • >= 1.0.0, < 1.15.0: Afectada
    • < 0.31.0: Afectada

    Sin corrección publicada

  • node-axios Debian:12

    Versiones
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    • 1.2.1+dfsg-1
    • 1.2.1+dfsg-1+deb12u1
    • 1.20.0-1
    • 1.5.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.8+dfsg-1
    • 1.6.8+dfsg-2
    • 1.7.3+dfsg-1
    • 1.7.4+dfsg-1
    • 1.7.7+dfsg-1
    • 1.7.9+dfsg-1
    • 1.8.4+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-axios Debian:13

    Versiones
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.18.0-1
    • 1.19.0-1
    • 1.20.0-1
    • 1.8.4+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-axios Debian:14

    Versiones
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.8.4+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.15.0-1

    Actualiza a 1.15.0-1

  • axios npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.0.0, < 1.15.0

    Actualiza a 1.15.0

  • axios npm

    Intervalos de versiones afectados
    • SEMVER: < 0.31.0

    Actualiza a 0.31.0

  • node-axios Ubuntu:Pro:20.04:LTS

    Versiones
    • 0.19.0+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.19.0+dfsg-2ubuntu0.1~esm1

    Actualiza a 0.19.0+dfsg-2ubuntu0.1~esm1

  • node-axios Ubuntu:Pro:22.04:LTS

    Versiones
    • 0.21.1+dfsg-1
    • 0.23.0+dfsg-2
    • 0.24.0+dfsg-1
    • 0.25.0+dfsg-2
    • 0.26.0+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.26.0+dfsg-1ubuntu0.1~esm1

    Actualiza a 0.26.0+dfsg-1ubuntu0.1~esm1

  • node-axios Ubuntu:Pro:24.04:LTS

    Versiones
    • 1.2.1+dfsg-1
    • 1.5.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.8+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.8+dfsg-2ubuntu0.1~esm1

    Actualiza a 1.6.8+dfsg-2ubuntu0.1~esm1

  • node-axios Ubuntu:25.10

    Versiones
    • 1.7.9+dfsg-1
    • 1.8.4+dfsg-1
    • 1.11.0+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-axios Ubuntu:Pro:26.04:LTS

    Versiones
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.2+dfsg-1build1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.13.2+dfsg-1ubuntu0.1~esm1

    Actualiza a 1.13.2+dfsg-1ubuntu0.1~esm1

Fuentes originales

Comprueba tu servidor →