p PatchFirst

CVE-2025-62800

CVE-2025-62800 · FastMCP vulnerable to reflected XSS in client's callback page

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

FastMCP is the standard framework for building MCP applications. Versions prior to 2.13.0 have a reflected cross-site scripting vulnerability in the OAuth client callback page (oauth_callback.py) where unescaped user-controlled values are inserted into the generated HTML, allowing arbitrary JavaScript execution in the callback server origin. The issue is fixed in version 2.13.0.

CVSS 5.3 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • fastmcp

    Versiones
    • < 2.13.0: Afectada

    Sin corrección publicada

  • fastmcp PyPI

    Versiones
    • 0.1.0
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.4.0
    • 0.4.1
    • 1.0
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.10.0
    • 2.10.1
    • 2.10.2
    • 2.10.3
    • 2.10.4
    • 2.10.5
    • 2.10.6
    • 2.11.0
    • 2.11.1
    • 2.11.2
    • 2.11.3
    • 2.12.0
    • 2.12.0rc1
    • 2.12.1
    • 2.12.2
    • 2.12.3
    • 2.12.4
    • 2.12.5
    • 2.13.0rc1
    • 2.13.0rc2
    • 2.13.0rc3
    • 2.2.0
    • 2.2.1
    • 2.2.10
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.2.9
    • 2.3.0
    • 2.3.0rc1
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.4.0
    • 2.5.0
    • 2.5.1
    • 2.5.2
    • 2.6.0
    • 2.6.1
    • 2.7.0
    • 2.7.1
    • 2.8.0
    • 2.8.1
    • 2.9.0
    • 2.9.1
    • 2.9.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.13.0

    Actualiza a 2.13.0

Fuentes originales

Comprueba tu servidor →