p PatchFirst

CVE-2025-64187

CVE-2025-64187 · OctoPrint is vulnerable to XSS through Action Command Notifications and Prompts

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

OctoPrint provides a web interface for controlling consumer 3D printers. Versions 1.11.3 and below are affected by a vulnerability that allows injection of arbitrary HTML and JavaScript into Action Command notifications and prompts popups generated by the printer. An attacker who successfully convinces a victim to print a specially crafted file could exploit this issue to disrupt ongoing prints, extract information (including sensitive configuration settings, if the targeted user has the necessary permissions for that), or perform other actions on behalf of the targeted user within the OctoPrint instance. This issue is fixed in version 1.11.4.

CVSS 4.6 · Media · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • octoprint

    Versiones
    • < 1.11.4: Afectada

    Sin corrección publicada

  • octoprint PyPI

    Versiones
    • 1.10.0
    • 1.10.0rc1
    • 1.10.0rc2
    • 1.10.0rc3
    • 1.10.0rc4
    • 1.10.1
    • 1.10.2
    • 1.10.3
    • 1.11.0
    • 1.11.0rc1
    • 1.11.0rc2
    • 1.11.0rc3
    • 1.11.0rc4
    • 1.11.0rc5
    • 1.11.0rc6
    • 1.11.0rc7
    • 1.11.1
    • 1.11.2
    • 1.11.3
    • 1.3.11
    • 1.3.12
    • 1.3.12rc1
    • 1.3.12rc3
    • 1.4.0
    • 1.4.0rc1
    • 1.4.0rc2
    • 1.4.0rc3
    • 1.4.0rc4
    • 1.4.0rc5
    • 1.4.0rc6
    • 1.4.1
    • 1.4.1rc1
    • 1.4.1rc2
    • 1.4.1rc3
    • 1.4.1rc4
    • 1.4.2
    • 1.5.0
    • 1.5.0rc1
    • 1.5.0rc2
    • 1.5.0rc3
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.6.0
    • 1.6.0rc1
    • 1.6.0rc2
    • 1.6.0rc3
    • 1.6.1
    • 1.7.0
    • 1.7.0rc1
    • 1.7.0rc2
    • 1.7.0rc3
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8.0
    • 1.8.0rc1
    • 1.8.0rc2
    • 1.8.0rc3
    • 1.8.0rc4
    • 1.8.0rc5
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.8.4
    • 1.8.5
    • 1.8.6
    • 1.8.7
    • 1.9.0
    • 1.9.0rc1
    • 1.9.0rc2
    • 1.9.0rc3
    • 1.9.0rc4
    • 1.9.0rc5
    • 1.9.0rc6
    • 1.9.1
    • 1.9.2
    • 1.9.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.11.4

    Actualiza a 1.11.4

Fuentes originales

Comprueba tu servidor →