p PatchFirst

CVE-2025-64329

CVE-2025-64329 · containerd CRI server: Host memory exhaustion through Attach goroutine leak

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

containerd is an open-source container runtime. Versions 1.7.28 and below, 2.0.0-beta.0 through 2.0.6, 2.1.0-beta.0 through 2.1.4, and 2.2.0-beta.0 through 2.2.0-rc.1 contain a bug in the CRI Attach implementation where a user can exhaust memory on the host due to goroutine leaks. This issue is fixed in versions 1.7.29, 2.0.7, 2.1.5 and 2.2.0. To workaround this vulnerability, users can set up an admission controller to control accesses to pods/attach resources.

CVSS 6.9 · Media · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · containers

Productos y versiones afectados

  • containerd

    Versiones
    • < 1.7.29: Afectada
    • < 2.0.7: Afectada
    • >= 2.1.0-beta.0, < 2.1.5: Afectada
    • >= 2.2.0-beta.0, < 2.2.0: Afectada

    Sin corrección publicada

  • containerd Debian:12

    Versiones
    • 1.6.20~ds1-1
    • 1.6.20~ds1-1+deb12u1
    • 1.6.20~ds1-1+deb12u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.20~ds1-1+deb12u3

    Actualiza a 1.6.20~ds1-1+deb12u3

  • containerd Debian:13

    Versiones
    • 1.7.24~ds1-6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.24~ds1-6+deb13u1

    Actualiza a 1.7.24~ds1-6+deb13u1

  • containerd Debian:14

    Versiones
    • 1.7.24~ds1-6
    • 1.7.24~ds1-7
    • 1.7.24~ds1-8
    • 1.7.24~ds1-9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.24~ds1-10

    Actualiza a 1.7.24~ds1-10

  • containerd Ubuntu:Pro:16.04:LTS

    Versiones
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    • 1.2.6-0ubuntu1~16.04.4
    • 1.2.6-0ubuntu1~16.04.5
    • 1.2.6-0ubuntu1~16.04.6
    • 1.2.6-0ubuntu1~16.04.6+esm1
    • 1.2.6-0ubuntu1~16.04.6+esm2
    • 1.2.6-0ubuntu1~16.04.6+esm4
    • 1.2.6-0ubuntu1~16.04.6+esm5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm6

    Actualiza a 1.2.6-0ubuntu1~16.04.6+esm6

  • containerd Ubuntu:Pro:18.04:LTS

    Versiones
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    • 1.5.2-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.3
    • 1.5.5-0ubuntu3~18.04.1
    • 1.5.5-0ubuntu3~18.04.2
    • 1.5.9-0ubuntu1~18.04.1
    • 1.5.9-0ubuntu1~18.04.2
    • 1.6.12-0ubuntu1~18.04.1
    • 1.6.12-0ubuntu1~18.04.1+esm1
    • 1.6.12-0ubuntu1~18.04.1+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.12-0ubuntu1~18.04.1+esm3

    Actualiza a 1.6.12-0ubuntu1~18.04.1+esm3

  • containerd Ubuntu:Pro:20.04:LTS

    Versiones
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    • 1.3.3-0ubuntu2.3
    • 1.4.4-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.1
    • 1.5.2-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.3
    • 1.5.5-0ubuntu3~20.04.1
    • 1.5.5-0ubuntu3~20.04.2
    • 1.5.9-0ubuntu1~20.04.1
    • 1.5.9-0ubuntu1~20.04.4
    • 1.5.9-0ubuntu1~20.04.5
    • 1.5.9-0ubuntu1~20.04.6
    • 1.6.12-0ubuntu1~20.04.1
    • 1.6.12-0ubuntu1~20.04.3
    • 1.6.12-0ubuntu1~20.04.5
    • 1.6.12-0ubuntu1~20.04.6
    • 1.6.12-0ubuntu1~20.04.7
    • 1.6.12-0ubuntu1~20.04.8
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.12-0ubuntu1~20.04.8+esm1

    Actualiza a 1.6.12-0ubuntu1~20.04.8+esm1

  • containerd-app Ubuntu:Pro:20.04:LTS

    Versiones
    • 1.7.2-0ubuntu1~20.04.1
    • 1.7.12-0ubuntu2~20.04.1
    • 1.7.24-0ubuntu1~20.04.1
    • 1.7.24-0ubuntu1~20.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.24-0ubuntu1~20.04.2+esm1

    Actualiza a 1.7.24-0ubuntu1~20.04.2+esm1

  • containerd Ubuntu:22.04:LTS

    Versiones
    • 1.5.5-0ubuntu3
    • 1.5.9-0ubuntu1
    • 1.5.9-0ubuntu2
    • 1.5.9-0ubuntu3
    • 1.5.9-0ubuntu3.1
    • 1.6.12-0ubuntu1~22.04.1
    • 1.6.12-0ubuntu1~22.04.3
    • 1.6.12-0ubuntu1~22.04.5
    • 1.6.12-0ubuntu1~22.04.6
    • 1.6.12-0ubuntu1~22.04.7
    • 1.6.12-0ubuntu1~22.04.8
    • 1.6.12-0ubuntu1~22.04.9
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.12-0ubuntu1~22.04.10

    Actualiza a 1.6.12-0ubuntu1~22.04.10

  • containerd-app Ubuntu:Pro:22.04:LTS

    Versiones
    • 1.7.2-0ubuntu1~22.04.1
    • 1.7.12-0ubuntu2~22.04.1
    • 1.7.24-0ubuntu1~22.04.1
    • 1.7.24-0ubuntu1~22.04.2
    • 1.7.27-0ubuntu1~22.04.1
    • 1.7.28-0ubuntu1~22.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.28-0ubuntu1~22.04.1+esm1

    Actualiza a 1.7.28-0ubuntu1~22.04.1+esm1

  • containerd-app Ubuntu:24.04:LTS

    Versiones
    • 1.7.2-0ubuntu2
    • 1.7.12-0ubuntu1
    • 1.7.12-0ubuntu2
    • 1.7.12-0ubuntu3
    • 1.7.12-0ubuntu4
    • 1.7.12-0ubuntu4.1
    • 1.7.19-0ubuntu1~24.04.1
    • 1.7.19+really1.7.12-0ubuntu4.2
    • 1.7.24-0ubuntu1~24.04.1
    • 1.7.24-0ubuntu1~24.04.2
    • 1.7.27-0ubuntu1~24.04.1
    • 1.7.28-0ubuntu1~24.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.28-0ubuntu1~24.04.2

    Actualiza a 1.7.28-0ubuntu1~24.04.2

  • containerd Ubuntu:Pro:24.04:LTS

    Versiones
    • 1.6.20~ds1-1ubuntu2
    • 1.6.24~ds1-1ubuntu1
    • 1.6.24~ds1-1ubuntu1.1
    • 1.6.24~ds1-1ubuntu1.2
    • 1.6.24~ds1-1ubuntu1.2+esm1
    • 1.6.24~ds1-1ubuntu1.3
    • 1.6.24~ds1-1ubuntu1.3+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.6.24~ds1-1ubuntu1.3+esm2

    Actualiza a 1.6.24~ds1-1ubuntu1.3+esm2

  • containerd Ubuntu:25.10

    Versiones
    • 1.7.24~ds1-5ubuntu1
    • 1.7.24~ds1-6ubuntu1
    • 1.7.24~ds1-8ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.7.24~ds1-8ubuntu1.1

    Actualiza a 1.7.24~ds1-8ubuntu1.1

  • containerd-app Ubuntu:25.10

    Versiones
    • 2.0.2-0ubuntu2
    • 2.0.5-0ubuntu1
    • 2.1.3-0ubuntu2
    • 2.1.3-0ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.3-0ubuntu3.1

    Actualiza a 2.1.3-0ubuntu3.1

Fuentes originales

Comprueba tu servidor →