CVE-2025-64496
CVE-2025-64496 · Open WebUI Affected by an External Model Server (Direct Connections) Code Injection via SSE Events
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Open WebUI is a self-hosted artificial intelligence platform designed to operate entirely offline. Versions 0.6.224 and prior contain a code injection vulnerability in the Direct Connections feature that allows malicious external model servers to execute arbitrary JavaScript in victim browsers via Server-Sent Event (SSE) execute events. This leads to authentication token theft, complete account takeover, and when chained with the Functions API, enables remote code execution on the backend server. The attack requires the victim to enable Direct Connections (disabled by default) and add the attacker's malicious model URL, achievable through social engineering of the admin and subsequent users. This issue is fixed in version 0.6.35.
CVSS 7.3 · Alta · EPSS 7,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python · node
Productos y versiones afectados
open-webui
- Versiones
- < 0.6.35: Afectada
Sin corrección publicada
open-webui npm
- Intervalos de versiones afectados
- SEMVER: < 0.6.35
Actualiza a 0.6.35
open-webui PyPI
- Versiones
- 0.1.124
- 0.1.125
- 0.2.0
- 0.2.1
- 0.2.2
- 0.2.3
- 0.2.4
- 0.2.5
- 0.3.0
- 0.3.1
- 0.3.10
- 0.3.12
- 0.3.13
- 0.3.14
- 0.3.15
- 0.3.16
- 0.3.17
- 0.3.17.dev2
- 0.3.17.dev3
- 0.3.17.dev4
- 0.3.17.dev5
- 0.3.18
- 0.3.19
- 0.3.2
- 0.3.20
- 0.3.21
- 0.3.22
- 0.3.23
- 0.3.24
- 0.3.25
- 0.3.26
- 0.3.27
- 0.3.27.dev1
- 0.3.27.dev2
- 0.3.27.dev3
- 0.3.28
- 0.3.29
- 0.3.3
- 0.3.30
- 0.3.30.dev1
- 0.3.30.dev2
- 0.3.31
- 0.3.31.dev1
- 0.3.32
- 0.3.33
- 0.3.33.dev1
- 0.3.34
- 0.3.35
- 0.3.4
- 0.3.5
- 0.3.6
- 0.3.7
- 0.3.8
- 0.3.9
- 0.4.0
- 0.4.0.dev1
- 0.4.0.dev2
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.4.5
- 0.4.6
- 0.4.6.dev1
- 0.4.7
- 0.4.8
- 0.5.0
- 0.5.0.dev1
- 0.5.0.dev2
- 0.5.1
- 0.5.10
- 0.5.11
- 0.5.12
- 0.5.13
- 0.5.14
- 0.5.15
- 0.5.16
- 0.5.17
- 0.5.18
- 0.5.19
- 0.5.2
- 0.5.20
- 0.5.3
- 0.5.3.dev1
- 0.5.4
- 0.5.5
- 0.5.6
- 0.5.7
- 0.5.8
- 0.5.9
- 0.6.0
- 0.6.1
- 0.6.10
- 0.6.11
- 0.6.12
- 0.6.13
- 0.6.14
- 0.6.15
- 0.6.16
- 0.6.18
- 0.6.19
- 0.6.2
- 0.6.20
- 0.6.21
- 0.6.22
- 0.6.23
- 0.6.24
- 0.6.25
- 0.6.26
- 0.6.26.dev1
- 0.6.27
- 0.6.28
- 0.6.29
- 0.6.3
- 0.6.30
- 0.6.31
- 0.6.32
- 0.6.33
- 0.6.34
- 0.6.4
- 0.6.5
- 0.6.6
- 0.6.6.dev1
- 0.6.7
- 0.6.8
- 0.6.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.6.35
Actualiza a 0.6.35