CVE-2025-65082
CVE-2025-65082 · Apache HTTP Server: CGI environment variable override
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache HTTP Server through environment variables set via the Apache configuration unexpectedly superseding variables calculated by the server for CGI programs. This issue affects Apache HTTP Server from 2.4.0 through 2.4.65. Users are recommended to upgrade to version 2.4.66 which fixes the issue.
CVSS 6.5 · Media · EPSS 0,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · web
Productos y versiones afectados
apache httpd
- Versiones
- ≥ 2.4.0, ≤ 2.4.65: Afectada (semver)
Sin corrección publicada
apache2 Debian:12
- Versiones
- 2.4.57-2
- 2.4.57-3
- 2.4.58-1
- 2.4.59-1
- 2.4.59-1~deb10u1
- 2.4.59-1~deb11u1
- 2.4.59-1~deb12u1
- 2.4.59-2
- 2.4.60-1
- 2.4.61-1
- 2.4.61-1~deb11u1
- 2.4.61-1~deb12u1
- 2.4.62-1
- 2.4.62-1~deb11u1
- 2.4.62-1~deb11u2
- 2.4.62-1~deb12u1
- 2.4.62-1~deb12u2
- 2.4.62-2
- 2.4.62-3
- 2.4.62-4
- 2.4.62-5
- 2.4.62-6
- 2.4.63-1
- 2.4.64-1
- 2.4.65-1
- 2.4.65-1~deb11u1
- 2.4.65-1~deb12u1
- 2.4.65-2
- 2.4.65-3
- 2.4.66-1~deb11u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.66-1~deb12u1
Actualiza a 2.4.66-1~deb12u1
apache2 Debian:13
- Versiones
- 2.4.65-2
- 2.4.65-3
- 2.4.66-1~deb11u1
- 2.4.66-1~deb12u1
- 2.4.66-1~deb12u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.66-1~deb13u1
Actualiza a 2.4.66-1~deb13u1
apache2 Debian:14
- Versiones
- 2.4.65-2
- 2.4.65-3
- 2.4.66-1~deb11u1
- 2.4.66-1~deb12u1
- 2.4.66-1~deb12u2
- 2.4.66-1~deb13u1
- 2.4.66-1~deb13u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.66-1
Actualiza a 2.4.66-1
apache2 Ubuntu:Pro:14.04:LTS
- Versiones
- 2.4.6-2ubuntu2
- 2.4.6-2ubuntu3
- 2.4.6-2ubuntu4
- 2.4.7-1ubuntu1
- 2.4.7-1ubuntu2
- 2.4.7-1ubuntu3
- 2.4.7-1ubuntu4
- 2.4.7-1ubuntu4.1
- 2.4.7-1ubuntu4.4
- 2.4.7-1ubuntu4.5
- 2.4.7-1ubuntu4.6
- 2.4.7-1ubuntu4.7
- 2.4.7-1ubuntu4.8
- 2.4.7-1ubuntu4.9
- 2.4.7-1ubuntu4.10
- 2.4.7-1ubuntu4.11
- 2.4.7-1ubuntu4.13
- 2.4.7-1ubuntu4.15
- 2.4.7-1ubuntu4.16
- 2.4.7-1ubuntu4.17
- 2.4.7-1ubuntu4.18
- 2.4.7-1ubuntu4.19
- 2.4.7-1ubuntu4.20
- 2.4.7-1ubuntu4.21
- 2.4.7-1ubuntu4.22
- 2.4.7-1ubuntu4.22+esm1
- 2.4.7-1ubuntu4.22+esm2
- 2.4.7-1ubuntu4.22+esm3
- 2.4.7-1ubuntu4.22+esm4
- 2.4.7-1ubuntu4.22+esm5
- 2.4.7-1ubuntu4.22+esm6
- 2.4.7-1ubuntu4.22+esm8
- 2.4.7-1ubuntu4.22+esm9
- 2.4.7-1ubuntu4.22+esm10
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.7-1ubuntu4.22+esm12
Actualiza a 2.4.7-1ubuntu4.22+esm12
apache2 Ubuntu:Pro:16.04:LTS
- Versiones
- 2.4.12-2ubuntu2
- 2.4.17-1ubuntu1
- 2.4.17-2ubuntu1
- 2.4.17-3ubuntu1
- 2.4.18-1ubuntu1
- 2.4.18-2ubuntu1
- 2.4.18-2ubuntu2
- 2.4.18-2ubuntu3
- 2.4.18-2ubuntu3.1
- 2.4.18-2ubuntu3.2
- 2.4.18-2ubuntu3.3
- 2.4.18-2ubuntu3.4
- 2.4.18-2ubuntu3.5
- 2.4.18-2ubuntu3.7
- 2.4.18-2ubuntu3.8
- 2.4.18-2ubuntu3.9
- 2.4.18-2ubuntu3.10
- 2.4.18-2ubuntu3.12
- 2.4.18-2ubuntu3.13
- 2.4.18-2ubuntu3.14
- 2.4.18-2ubuntu3.15
- 2.4.18-2ubuntu3.17
- 2.4.18-2ubuntu3.17+esm1
- 2.4.18-2ubuntu3.17+esm2
- 2.4.18-2ubuntu3.17+esm3
- 2.4.18-2ubuntu3.17+esm4
- 2.4.18-2ubuntu3.17+esm5
- 2.4.18-2ubuntu3.17+esm6
- 2.4.18-2ubuntu3.17+esm7
- 2.4.18-2ubuntu3.17+esm8
- 2.4.18-2ubuntu3.17+esm9
- 2.4.18-2ubuntu3.17+esm10
- 2.4.18-2ubuntu3.17+esm11
- 2.4.18-2ubuntu3.17+esm12
- 2.4.18-2ubuntu3.17+esm13
- 2.4.18-2ubuntu3.17+esm14
- 2.4.18-2ubuntu3.17+esm16
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.18-2ubuntu3.17+esm17
Actualiza a 2.4.18-2ubuntu3.17+esm17
apache2 Ubuntu:Pro:18.04:LTS
- Versiones
- 2.4.27-2ubuntu3
- 2.4.29-1ubuntu1
- 2.4.29-1ubuntu2
- 2.4.29-1ubuntu3
- 2.4.29-1ubuntu4
- 2.4.29-1ubuntu4.1
- 2.4.29-1ubuntu4.2
- 2.4.29-1ubuntu4.3
- 2.4.29-1ubuntu4.4
- 2.4.29-1ubuntu4.5
- 2.4.29-1ubuntu4.6
- 2.4.29-1ubuntu4.7
- 2.4.29-1ubuntu4.8
- 2.4.29-1ubuntu4.10
- 2.4.29-1ubuntu4.11
- 2.4.29-1ubuntu4.12
- 2.4.29-1ubuntu4.13
- 2.4.29-1ubuntu4.14
- 2.4.29-1ubuntu4.16
- 2.4.29-1ubuntu4.17
- 2.4.29-1ubuntu4.18
- 2.4.29-1ubuntu4.19
- 2.4.29-1ubuntu4.20
- 2.4.29-1ubuntu4.21
- 2.4.29-1ubuntu4.22
- 2.4.29-1ubuntu4.23
- 2.4.29-1ubuntu4.24
- 2.4.29-1ubuntu4.25
- 2.4.29-1ubuntu4.26
- 2.4.29-1ubuntu4.27
- 2.4.29-1ubuntu4.27+esm1
- 2.4.29-1ubuntu4.27+esm2
- 2.4.29-1ubuntu4.27+esm3
- 2.4.29-1ubuntu4.27+esm4
- 2.4.29-1ubuntu4.27+esm6
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.29-1ubuntu4.27+esm7
Actualiza a 2.4.29-1ubuntu4.27+esm7
apache2 Ubuntu:Pro:20.04:LTS
- Versiones
- 2.4.41-1ubuntu1
- 2.4.41-4ubuntu1
- 2.4.41-4ubuntu2
- 2.4.41-4ubuntu3
- 2.4.41-4ubuntu3.1
- 2.4.41-4ubuntu3.3
- 2.4.41-4ubuntu3.4
- 2.4.41-4ubuntu3.5
- 2.4.41-4ubuntu3.6
- 2.4.41-4ubuntu3.7
- 2.4.41-4ubuntu3.8
- 2.4.41-4ubuntu3.9
- 2.4.41-4ubuntu3.10
- 2.4.41-4ubuntu3.11
- 2.4.41-4ubuntu3.12
- 2.4.41-4ubuntu3.13
- 2.4.41-4ubuntu3.14
- 2.4.41-4ubuntu3.15
- 2.4.41-4ubuntu3.16
- 2.4.41-4ubuntu3.17
- 2.4.41-4ubuntu3.19
- 2.4.41-4ubuntu3.20
- 2.4.41-4ubuntu3.21
- 2.4.41-4ubuntu3.23
- 2.4.41-4ubuntu3.23+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.41-4ubuntu3.23+esm3
Actualiza a 2.4.41-4ubuntu3.23+esm3
apache2 Ubuntu:22.04:LTS
- Versiones
- 2.4.48-3.1ubuntu3
- 2.4.48-3.1ubuntu4
- 2.4.51-2ubuntu1
- 2.4.52-1ubuntu1
- 2.4.52-1ubuntu2
- 2.4.52-1ubuntu4
- 2.4.52-1ubuntu4.1
- 2.4.52-1ubuntu4.2
- 2.4.52-1ubuntu4.3
- 2.4.52-1ubuntu4.4
- 2.4.52-1ubuntu4.5
- 2.4.52-1ubuntu4.6
- 2.4.52-1ubuntu4.7
- 2.4.52-1ubuntu4.8
- 2.4.52-1ubuntu4.9
- 2.4.52-1ubuntu4.10
- 2.4.52-1ubuntu4.11
- 2.4.52-1ubuntu4.12
- 2.4.52-1ubuntu4.13
- 2.4.52-1ubuntu4.14
- 2.4.52-1ubuntu4.15
- 2.4.52-1ubuntu4.16
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.52-1ubuntu4.18
Actualiza a 2.4.52-1ubuntu4.18
apache2 Ubuntu:24.04:LTS
- Versiones
- 2.4.57-2ubuntu2
- 2.4.57-2ubuntu3
- 2.4.58-1ubuntu1
- 2.4.58-1ubuntu2
- 2.4.58-1ubuntu6
- 2.4.58-1ubuntu7
- 2.4.58-1ubuntu8
- 2.4.58-1ubuntu8.1
- 2.4.58-1ubuntu8.2
- 2.4.58-1ubuntu8.3
- 2.4.58-1ubuntu8.4
- 2.4.58-1ubuntu8.5
- 2.4.58-1ubuntu8.6
- 2.4.58-1ubuntu8.7
- 2.4.58-1ubuntu8.8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.58-1ubuntu8.10
Actualiza a 2.4.58-1ubuntu8.10
apache2 Ubuntu:25.10
- Versiones
- 2.4.63-1ubuntu1
- 2.4.63-1ubuntu3
- 2.4.64-1ubuntu2
- 2.4.64-1ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.64-1ubuntu3.2
Actualiza a 2.4.64-1ubuntu3.2
apache2 Ubuntu:26.04:LTS
- Versiones
- 2.4.64-1ubuntu3
- 2.4.65-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.66-2ubuntu1
Actualiza a 2.4.66-2ubuntu1