p PatchFirst

CVE-2026-101896

CVE-2026-101896 · Angular: Denial of Service via Numeric URL Matrix Parameters in Server-Side Rendering (SSR)

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.32, 21.2.24, and 22.2.0, the @angular/router URL parser stores numeric matrix parameter names and numeric outlet names as properties on initially empty JavaScript objects during Node.js server-side rendering. V8 can interpret these URL-derived keys as array indices and allocate dense backing stores sized to high numeric values, so repeated small path segments cause disproportionate per-segment heap consumption. An unauthenticated attacker can send overlapping requests containing repeated numeric matrix parameters when SSR is enabled, the router directly parses the request URL, and upstream proxies allow semicolons and multiple path segments, eventually exhausting the Node.js old-space heap and terminating the SSR worker. Pure client-side Angular applications are not affected. This issue is fixed in versions 20.3.32, 21.2.24, and 22.2.0.

CVSS 8.2 · Alta · EPSS 0,8% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • angular

    Versiones
    • <= 19.2.25: Afectada
    • >= 20.0.0, < 20.3.32: Afectada
    • >= 21.0.0, < 21.2.24: Afectada
    • >= 22.0.0, < 22.2.0: Afectada

    Sin corrección publicada

  • router

    Versiones
    • <= 19.2.25: Afectada
    • >= 20.0.0, < 20.3.32: Afectada
    • >= 21.0.0, < 21.2.24: Afectada
    • >= 22.0.0, < 22.2.0: Afectada

    Sin corrección publicada

  • angular.js Debian:12

    Versiones
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Debian:13

    Versiones
    • 1.8.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • @angular/router npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 22.0.0, < 22.2.0

    Actualiza a 22.2.0

  • @angular/router npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 21.0.0, < 21.2.24

    Actualiza a 21.2.24

  • @angular/router npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 20.0.0, < 20.3.32

    Actualiza a 20.3.32

  • @angular/router npm

    Intervalos de versiones afectados
    • SEMVER: ≤ 19.2.25

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →