CVE-2026-101917
CVE-2026-101917 · PyJWT: PyJWKClient still amplifies unauthenticated JWKS fetches on unknown kid values (incomplete fix of CVE-2026-48524)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
PyJWT is a Python implementation of JSON Web Token standards. Prior to 2.14.0, PyJWT get_signing_key_from_jwt is affected because unknown kid misses force refreshes without a negative cache or minimum refresh interval. This occurs when unauthenticated tokens repeatedly use the same unknown kid or varying kid values absent from the cached JWKS. As a result, each cache miss causes PyJWKClient to refresh the JWKS. Consequently, attacker traffic can amplify outbound requests to the configured JWKS endpoint. This issue is fixed in version 2.14.0.
CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
pyjwt
- Versiones
- < 2.14.0: Afectada
Sin corrección publicada
pyjwt Debian:12
- Versiones
- 2.10.1-1
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- 2.6.0-1
- 2.6.0-1+deb12u1
- 2.7.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pyjwt Debian:13
- Versiones
- 2.10.1-2
- 2.10.1-2+deb13u1
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pyjwt Debian:14
- Versiones
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.14.0-1
Actualiza a 2.14.0-1
pyjwt PyPI
- Versiones
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.1.7
- 0.1.8
- 0.1.9
- 0.2.0
- 0.2.1
- 0.2.3
- 0.3.0
- 0.3.1
- 0.3.2
- 0.4.0
- 0.4.1
- 0.4.2
- 0.4.3
- 1.0.0
- 1.0.1
- 1.1.0
- 1.3.0
- 1.4.0
- 1.4.1
- 1.4.2
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.3
- 1.6.4
- 1.7.0
- 1.7.1
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.1
- 2.1.0
- 2.10.0
- 2.10.1
- 2.11.0
- 2.12.0
- 2.12.1
- 2.13.0
- 2.2.0
- 2.3.0
- 2.4.0
- 2.5.0
- 2.6.0
- 2.7.0
- 2.8.0
- 2.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.14.0
Actualiza a 2.14.0
pyjwt Ubuntu:22.04:LTS
- Versiones
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- 2.3.0-1ubuntu0.1
- 2.3.0-1ubuntu0.2
- 2.3.0-1ubuntu0.3
- 2.3.0-1ubuntu0.4
- 2.3.0-1ubuntu0.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.0-1ubuntu0.6
Actualiza a 2.3.0-1ubuntu0.6
pyjwt Ubuntu:24.04:LTS
- Versiones
- 2.7.0-1
- 2.7.0-1ubuntu0.1
- 2.7.0-1ubuntu0.2
- 2.7.0-1ubuntu0.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.0-1ubuntu0.4
Actualiza a 2.7.0-1ubuntu0.4
pyjwt Ubuntu:26.10
- Versiones
- 2.10.1-4ubuntu1
- 2.12.1-1
- 2.13.0-1
- 2.13.0-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.13.0-1ubuntu1.1
Actualiza a 2.13.0-1ubuntu1.1
pyjwt Ubuntu:26.04:LTS
- Versiones
- 2.10.1-2
- 2.10.1-3
- 2.10.1-3build1
- 2.10.1-4
- 2.10.1-4ubuntu1
- 2.10.1-4ubuntu1.1
- 2.10.1-4ubuntu1.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.10.1-4ubuntu1.3
Actualiza a 2.10.1-4ubuntu1.3