CVE-2026-102828
CVE-2026-102828 · simple-git unsafe-operation guard does not block trailer command configuration
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
simple-git, an interface for running git commands in any node.js application, enables applications to execute Git operations from JavaScript. From 3.15.0 until 4.0.1, the default blockUnsafeOperationsPlugin does not classify trailer.<token>.cmd as unsafe configuration. An application that passes attacker-controlled values through SimpleGitOptions.config or inline -c arguments can therefore allow Git to invoke an attacker-selected shell command when git interpret-trailers processes the configured trailer. The command executes with the operating-system identity and permissions of the Node.js process. This issue is fixed in 4.0.1.
CVSS 9.2 · Crítica · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: node
Productos y versiones afectados
git-js
- Versiones
- >= 3.15.0, < 4.0.1: Afectada
Sin corrección publicada
simple-git npm
- Intervalos de versiones afectados
- SEMVER: ≥ 3.15.0, < 4.0.1
Actualiza a 4.0.1
Fuentes originales
- https://github.com/steveukx/git-js/security/advisories/GHSA-x6jw-m9v5-85vh
- https://github.com/steveukx/git-js/pull/1198
- https://github.com/steveukx/git-js/commit/d762810c13b331ff1e5eb24c0b434646d2a8d1b3
- https://github.com/steveukx/git-js/releases/tag/[email protected]
- https://nvd.nist.gov/vuln/detail/CVE-2026-102828