CVE-2026-102990
CVE-2026-102990 · basic-ftp: Quadratic-time CPU denial of service in Client.list() Unix directory-listing parser (RE_LINE backtracking)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
basic-ftp is an FTP client for Node.js. Prior to 6.2.1, Client.list() can be forced by a malicious or compromised FTP server to spend quadratic CPU time parsing a directory listing because the RE_LINE expression in src/parseListUnix.ts backtracks across adjacent variable-length owner and group fields when a long Unix-style line has a valid prefix but cannot satisfy the later size and date fields. parseList() selects a parser from the last nonblank line and then applies it to every line, so a normal final line can select the Unix parser while an earlier crafted line blocks the Node.js event loop and freezes the process. This issue is fixed in version 6.2.1.
CVSS 8.2 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
basic-ftp
- Versiones
- < 6.2.1: Afectada
Sin corrección publicada
node-proxy-agents Debian:13
- Versiones
- 0~2024040606-6
- 0~2024040606-6+deb13u1
- 0~2025070717+~cs15.2.7-1
- 0~2025070717+~cs15.3.7-1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- 0~2025070717+~cs16.2.9-1
- 0~2025070717-1
- 0~2025070717-2
- 0~2025070717-3
- 0~2025070717-4
- 0~2025070717-5
- 0~2025070717-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-proxy-agents Debian:14
- Versiones
- 0~2024040606-6
- 0~2025070717+~cs15.2.7-1
- 0~2025070717+~cs15.3.7-1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- 0~2025070717-1
- 0~2025070717-2
- 0~2025070717-3
- 0~2025070717-4
- 0~2025070717-5
- 0~2025070717-6
- Intervalos de versiones afectados
- ECOSYSTEM: < 0~2025070717+~cs16.2.9-1
Actualiza a 0~2025070717+~cs16.2.9-1
basic-ftp npm
- Intervalos de versiones afectados
- SEMVER: < 6.2.1
Actualiza a 6.2.1
node-proxy-agents Ubuntu:24.04:LTS
- Versiones
- 0~2023071921-5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-proxy-agents Ubuntu:26.10
- Versiones
- 0~2025070717+~cs15.2.7-1build1
- 0~2025070717+~cs15.3.8-1
- 0~2025070717+~cs15.3.8-2
- 0~2025070717+~cs15.3.8-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-proxy-agents Ubuntu:26.04:LTS
- Versiones
- 0~2025070717-2
- 0~2025070717-6
- 0~2025070717+~cs15.2.7-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada