CVE-2026-104851
CVE-2026-104851 · fsspec: Server-Side Template Injection in ReferenceFileSystem leads to Remote Code Execution
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
fsspec is a specification and Python implementation framework for filesystem interfaces. From 0.9.0 until 2026.6.0, fsspec.implementations.reference.ReferenceFileSystem evaluates fields from Kerchunk reference JSON documents through unrestricted jinja2.Template(...).render(...) calls in _process_references1._render_jinja, _process_templates, and _process_gen in fsspec/implementations/reference.py. A document supplied inline or fetched from an attacker-controlled URL can provide template expressions that execute Python code when the reference filesystem is opened, including through consumers such as xarray, before referenced data is read. The _process_gen path is reached whenever a document includes a gen array, while the other paths depend on template-related options and values. This issue is fixed in version 2026.6.0.
CVSS 8.8 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
filesystem_spec
- Versiones
- >= 0.9.0, < 2026.6.0: Afectada
Sin corrección publicada
fsspec Debian:12
- Versiones
- 2022.11.0-1
- 2023.10.0-1
- 2023.3.0-1~exp1
- 2023.6.0-1
- 2023.9.2-1
- 2024.10.0-1
- 2024.12.0-1
- 2024.12.0-2
- 2024.2.0-1
- 2024.3.1-1
- 2024.5.0-1
- 2024.6.0-1
- 2024.6.1-1
- 2024.9.0-1
- 2025.12.0-1
- 2025.2.0-1
- 2025.3.0-1
- 2025.3.2-1
- 2025.7.0-1
- 2025.7.0-2
- 2025.7.0-3
- 2025.7.0-4
- 2026.9.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
fsspec Debian:13
- Versiones
- 2025.12.0-1
- 2025.3.2-1
- 2025.7.0-1
- 2025.7.0-2
- 2025.7.0-3
- 2025.7.0-4
- 2026.9.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
fsspec Debian:14
- Versiones
- 2025.12.0-1
- 2025.3.2-1
- 2025.7.0-1
- 2025.7.0-2
- 2025.7.0-3
- 2025.7.0-4
- Intervalos de versiones afectados
- ECOSYSTEM: < 2026.9.0-1
Actualiza a 2026.9.0-1
fsspec PyPI
- Versiones
- 0.9.0
- 2021.10.0
- 2021.10.1
- 2021.11.0
- 2021.11.1
- 2021.4.0
- 2021.5.0
- 2021.6.0
- 2021.6.1
- 2021.7.0
- 2021.8.1
- 2021.9.0
- 2022.1.0
- 2022.10.0
- 2022.11.0
- 2022.2.0
- 2022.3.0
- 2022.5.0
- 2022.7.0
- 2022.7.1
- 2022.8.0
- 2022.8.1
- 2022.8.2
- 2023.1.0
- 2023.10.0
- 2023.12.0
- 2023.12.1
- 2023.12.2
- 2023.3.0
- 2023.4.0
- 2023.5.0
- 2023.6.0
- 2023.9.0
- 2023.9.1
- 2023.9.2
- 2024.10.0
- 2024.12.0
- 2024.2.0
- 2024.3.0
- 2024.3.1
- 2024.5.0
- 2024.6.0
- 2024.6.1
- 2024.9.0
- 2025.10.0
- 2025.12.0
- 2025.2.0
- 2025.3.0
- 2025.3.1
- 2025.3.2
- 2025.5.0
- 2025.5.1
- 2025.7.0
- 2025.9.0
- 2026.1.0
- 2026.2.0
- 2026.3.0
- 2026.4.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.9.0, < 2026.6.0
Actualiza a 2026.6.0
fsspec Ubuntu:20.04:LTS
- Versiones
- 0.6.1-0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
fsspec Ubuntu:22.04:LTS
- Versiones
- 0.8.4-1
- 2022.01.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
fsspec Ubuntu:24.04:LTS
- Versiones
- 2023.6.0-1
- 2023.9.2-1
- 2023.10.0-1
- 2024.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
fsspec Ubuntu:26.10
- Versiones
- 2025.12.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
fsspec Ubuntu:26.04:LTS
- Versiones
- 2025.3.2-1ubuntu1
- 2025.12.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/fsspec/filesystem_spec/security/advisories/GHSA-27vj-qcqg-25rc
- https://github.com/fsspec/filesystem_spec/pull/2029
- https://github.com/fsspec/filesystem_spec/pull/2039
- https://github.com/fsspec/filesystem_spec/commit/86438783f93b1398ef245b92f0e6063b445b611c
- https://github.com/fsspec/filesystem_spec/commit/a1c16ab3f07f354aa371c38f7b1b07ea7fd4c5c8
- https://github.com/fsspec/filesystem_spec/releases/tag/2026.6.0
- https://nvd.nist.gov/vuln/detail/CVE-2026-104851